Bug 209133 - CodeCompletion took 2214 ms.
CodeCompletion took 2214 ms.
Status: RESOLVED INCOMPLETE
Product: editor
Classification: Unclassified
Component: Completion & Templates
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Dusan Balek
issues@editor
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-04 09:01 UTC by Chiana
Modified: 2012-05-30 14:13 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (55.39 KB, application/nps)
2012-03-04 09:01 UTC, Chiana
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chiana 2012-03-04 09:01:38 UTC
This bug was originally marked as duplicate of bug 186010, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201203030400)
VM: Java HotSpot(TM) 64-Bit Server VM, 22.1-b02, Java(TM) SE Runtime Environment, 1.7.0_03-b05
OS: Windows 7

User Comments:
Chiana: Was just editing, nothing special.

Also notices SEVERE delays in the hint windows, takes up to 30 seconds to get the info.



Maximum slowness yet reported was 2214 ms, average is 2214
Comment 1 Chiana 2012-03-04 09:01:43 UTC
Created attachment 116319 [details]
nps snapshot
Comment 2 Petr Cyhelsky 2012-05-30 11:17:57 UTC
ressigning to code completion
Comment 3 Dusan Balek 2012-05-30 14:13:15 UTC
From the attached snapshot it seems that some of compiled sources are inside jar/zip file. What is your project configuration?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo