Bug 209130 - Stepping doesn't work when "auto start process after program is loaded" is enabled
Stepping doesn't work when "auto start process after program is loaded" is en...
Status: RESOLVED DUPLICATE of bug 200196
Product: cnd
Classification: Unclassified
Component: Debugger
7.1.1
PC Linux
: P3 (vote)
: TBD
Assigned To: Egor Ushakov
issues@cnd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-03 22:12 UTC by tmikov
Modified: 2012-04-16 16:37 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tmikov 2012-03-03 22:12:21 UTC
Ubuntu 10.04/x86 Netbeans 7.1.1
When "auto start process after program is loaded" is enabled, stepping doesn't work when debugging. When "Step Over" or "Step Into" is invoked, it just continues executing the program freely, until it completes or hits a breakpoint. Breakpoints do work.

This seems related to http://netbeans.org/bugzilla/show_bug.cgi?id=202153, which is marked as fixed.

Disabling "auto start process after program is loaded" seems to fix it.
Comment 1 Egor Ushakov 2012-04-16 16:37:43 UTC
look more like bug 200196

*** This bug has been marked as a duplicate of bug 200196 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo