Bug 209113 - speed up creation of project from existing sources
speed up creation of project from existing sources
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Project
7.2
All All
: P3 (vote)
: 8.0
Assigned To: Alexander Simon
issues@cnd
: 7.2_WAIVER_APPROVED
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-02 15:20 UTC by Vladimir Voskresensky
Modified: 2013-01-29 03:28 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Voskresensky 2012-03-02 15:20:23 UTC
When create project from existing sources using custom clean/build the following problem occurs:
- after pressing Finish on the last dialog I have two wait 10 minutes, because source root is rather big
after that
- clean & build starts which also takes for my project about 10-15 minutes

Some enhancements are needed:
- show project with project Loading... state immediate and start clean & build process

It helps especially when clean fails and I have to repeat project creation. Lost 10 minutes is real issue.
Comment 1 Vladimir Voskresensky 2012-03-02 15:23:44 UTC
first 10 minutes IDE is doing:
"wizard-descriptor-asynchronous-jobs" daemon prio=3 tid=0x08f98000 nid=0x31 runnable [0x1adff000]
   java.lang.Thread.State: RUNNABLE
        at java.lang.Class.getClassLoader0(Native Method)
        at java.lang.Class.getClassLoader(Class.java:587)
        at org.netbeans.core.startup.preferences.PreferencesProviderImpl.preferencesForModule(PreferencesProviderImpl.java:63)
        at org.openide.util.NbPreferences.forModule(NbPreferences.java:76)
        at org.netbeans.modules.cnd.makeproject.MakeOptions.getPreferences(MakeOptions.java:111)
        at org.netbeans.modules.cnd.makeproject.MakeOptions.getPathMode(MakeOptions.java:130)
        at org.netbeans.modules.cnd.makeproject.api.MakeProjectOptions.getPathMode(MakeProjectOptions.java:91)
        at org.netbeans.modules.cnd.makeproject.api.ProjectSupport.getPathMode(ProjectSupport.java:120)
        at org.netbeans.modules.cnd.makeproject.api.ProjectSupport.toProperPath(ProjectSupport.java:124)
        at org.netbeans.modules.cnd.makeproject.api.configurations.MakeConfigurationDescriptor.addFiles(MakeConfigurationDescriptor.java:1807)
        at org.netbeans.modules.cnd.makeproject.api.configurations.MakeConfigurationDescriptor.addFiles(MakeConfigurationDescriptor.java:1805)
        at org.netbeans.modules.cnd.makeproject.api.configurations.MakeConfigurationDescriptor.addFiles(MakeConfigurationDescriptor.java:1805)
        at org.netbeans.modules.cnd.makeproject.api.configurations.MakeConfigurationDescriptor.addFiles(MakeConfigurationDescriptor.java:1805)
        at org.netbeans.modules.cnd.makeproject.api.configurations.MakeConfigurationDescriptor.addFiles(MakeConfigurationDescriptor.java:1805)
        at org.netbeans.modules.cnd.makeproject.api.configurations.MakeConfigurationDescriptor.addFilesFromRoot(MakeConfigurationDescriptor.java:1723)
        at org.netbeans.modules.cnd.makeproject.api.configurations.MakeConfigurationDescriptor.initLogicalFolders(MakeConfigurationDescriptor.java:366)
        at org.netbeans.modules.cnd.makeproject.MakeProjectGeneratorImpl$1.run(MakeProjectGeneratorImpl.java:283)
        at org.netbeans.modules.cnd.makeproject.MakeProjectGeneratorImpl.createProject(MakeProjectGeneratorImpl.java:295)
        at org.netbeans.modules.cnd.makeproject.MakeProjectGeneratorImpl.createProject(MakeProjectGeneratorImpl.java:183)
        at org.netbeans.modules.cnd.makeproject.api.ProjectGenerator.createProject(ProjectGenerator.java:410)
        at org.netbeans.modules.cnd.discovery.projectimport.ImportProject.create(ImportProject.java:371)
        at org.netbeans.modules.cnd.discovery.wizard.DiscoveryExtension.createProject(DiscoveryExtension.java:104)
        at org.netbeans.modules.cnd.makeproject.ui.wizards.NewMakeProjectWizardIterator.instantiate(NewMakeProjectWizardIterator.java:429)
        at org.netbeans.modules.cnd.makeproject.ui.wizards.NewMakeProjectWizardIterator.instantiate(NewMakeProjectWizardIterator.java:395)
        at org.openide.loaders.TemplateWizard$InstantiatingIteratorBridge.instantiate(TemplateWizard.java:1020)
        at org.openide.loaders.TemplateWizard.handleInstantiate(TemplateWizard.java:587)
        at org.openide.loaders.TemplateWizard.instantiateNewObjects(TemplateWizard.java:426)
        at org.openide.loaders.TemplateWizardIterImpl.instantiate(TemplateWizardIterImpl.java:252)
        at org.openide.loaders.TemplateWizardIteratorWrapper$ProgressInstantiatingIterator.instantiate(TemplateWizardIteratorWrapper.java:180)
        at org.openide.WizardDescriptor.callInstantiateOpen(WizardDescriptor.java:1566)
        at org.openide.WizardDescriptor.callInstantiate(WizardDescriptor.java:1521)
        at org.openide.WizardDescriptor.access$1800(WizardDescriptor.java:139)
        at org.openide.WizardDescriptor$Listener$2$1.run(WizardDescriptor.java:2134)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1411)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1991)
Comment 2 Vladimir Voskresensky 2012-03-02 15:24:39 UTC
that's simulation what Egor have seen in odb group
Comment 3 Vladimir Voskresensky 2012-03-28 11:41:50 UTC
Let me formulate user expectations:
- user gone though all pages of Project From Existing Sources wizard and allowed IDE do clean&build on step 2
- On last page user specify all information about project Name and Location and press Finish
- user sees in Project tab project with name Name and one subnode "Creating Project..." and at the same time he sees Output Window where clean&build is in progress
- during "Loading..." phase project's context menu has only one enabled choice:Cancel Project Creation
Comment 4 Leonid Lenyashin 2012-09-11 12:38:07 UTC
The problem is serious but has very little (if any) impact on NetBeans community. I'd expect this problem to be solved as part of project-less exercise, is it a correct expectation? If it is it can be waived.
Comment 5 igor_nikiforov 2012-09-13 07:51:14 UTC
Downgrading to P3.

Reasons:
  - not a problem for NetBeans users;
  - for OSS users workaround is available: offline project creation;
  - ProjectLess not going to have this problem by design.
Comment 6 Alexander Simon 2013-01-28 13:36:08 UTC
fixed, change set:
http://hg.netbeans.org/cnd-main/rev/e06967eb73de
Comment 7 Quality Engineering 2013-01-29 03:28:37 UTC
Integrated into 'main-golden', will be available in build *201301290001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/e06967eb73de
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #209113 speed up creation of project from existing sources


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo