Bug 209078 - 130s - remote.impl.fs.RemoteFileSystem.getActions()
130s - remote.impl.fs.RemoteFileSystem.getActions()
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: -- Other --
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Andrew Krasny
issues@cnd
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-02 03:04 UTC by Alexander Simon
Modified: 2012-04-05 08:59 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (278.60 KB, application/nps)
2012-03-02 03:04 UTC, Alexander Simon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Simon 2012-03-02 03:04:39 UTC
Build: NetBeans IDE Dev (Build 20120301-2ebbcaeb2275)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.1-b02, Java(TM) SE Runtime Environment, 1.6.0_26-b03
OS: Linux
Maximum slowness yet reported was 130091 ms, average is 66829
Comment 1 Alexander Simon 2012-03-02 03:04:44 UTC
Created attachment 116271 [details]
nps snapshot
Comment 2 Ondrej Vrabec 2012-03-22 11:39:36 UTC
What i see in the snapshot is huge time spent in ADE and remote FS implementation, what makes you think it should be filed against VCS core?
Comment 3 Andrew Krasny 2012-03-28 15:57:32 UTC
partly fixed with sputnik-main:378dc67cedfb
Comment 4 Andrew Krasny 2012-04-04 22:10:22 UTC
I will close this issue as the part that people complains about was fixed.
Other aspects of slowness in getActions() caused by rfs and several issues were filed on this.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo