Bug 208984 - Not ignored files displayed grey (I) in projects and files window
Not ignored files displayed grey (I) in projects and files window
Status: RESOLVED DUPLICATE of bug 207700
Product: versioncontrol
Classification: Unclassified
Component: Git
7.1
Macintosh Mac OS X
: P3 (vote)
: TBD
Assigned To: Ondrej Vrabec
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 04:48 UTC by sheershoff
Modified: 2013-12-18 08:27 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
.gitignore file says only the /web/bundles/ folder is ignored, but some other files in /web folder appear as ignored too. (239.92 KB, image/png)
2013-12-18 08:27 UTC, david.zapata
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sheershoff 2012-02-29 04:48:05 UTC
Netbeans displays one folder and all underlying files as ignored by VCS (I use Git), but when I use git status or Atlassian SourceTree the files are not ignored and listed as changed and ready for commit. When i control-click the directories www and www/inc - Git and Local history are displayed in the pop-up menu, so I believe it's Git module issue.

Specifically NetBeans IDE 7.1 (Build 201112071828) - PHP build, Git plugin version: 1.1.1.1 (shipped with NetBeans IDE 7.1 (Build 201112071828)), CLI git version 1.7.5.4

The ignored folder is www/inc . Unignoring doesn't help. Ignoring and unignoring again changes the .gitignore file accordingly, but the folder is still displayed grey with (I) - the ignored status marker. Also I've noticed some buggy behavior: subfolders of www/inc often turn grey only if I unfold them to see their content, but sometimes they turn grey when I unfold the already grey www/inc.

I checked .gitignore in the top project folder and all the way to ignored one and in the whole project source tree. There's only one file and it states

/nbproject/private/
/log/
/www/debuglogs/*.log
/www/images/goods/*/*
/www/inc/content/

The .git/config file doesn't contain any mentions of ignoring. In ~/.gitconfig global gitignore is defined as /Users/sheershoff/.gitignore_global and the global ignore file is the following:

*~
.DS_Store

There's no .git/info folder in local Git repository, and the remote bare repository has the project.git/info/exclude file, but it consists of several commented out lines, which, I believe, are default.

Concerning Netbeans, I tried cleaning out cache folder and setting global IDE ignored files settings (Tools->Options->Miscellaneous->Files) to an empty string and restarting the IDE. Also I checked project ignored folders settings - it is empty.

After hours of resultless but effortful digging and googling I managed to resolve similar problem on Windows machine (same Netbeans build number) with the same project pulled from the same remote repo with the same folder disrespectfully ignored by editing some Netbeans properties files (should I mention the ignore.path setting is empty here and was empty there on Windows, and I also set all the includes settings to empty strings since I don't use them in the project). And as far as I can remember, it was something with includes section, not with ignore section. Though, can't find it in the repo history, probably it was in the private netbeans project settings or some global netbeans settings.

And now this bug repeats on my Mac machine at work and nothing helps me to make Netbeans display the not ignored files as not ignored.
Comment 1 Ondrej Vrabec 2012-03-13 13:33:08 UTC
If you remove this line from .gitignore:
> /www/images/goods/*/*
and restart the IDE, does it help?
Comment 2 sheershoff 2012-03-26 11:18:53 UTC
(In reply to comment #1)
> If you remove this line from .gitignore:
> > /www/images/goods/*/*
> and restart the IDE, does it help?

Yes, it helped.
Comment 3 Ondrej Vrabec 2012-04-02 13:18:27 UTC

*** This bug has been marked as a duplicate of bug 207700 ***
Comment 4 david.zapata 2013-12-18 08:27:01 UTC
Created attachment 143286 [details]
.gitignore file says only the /web/bundles/ folder is ignored, but some other files in /web folder appear as ignored too.

.gitignore file says only the /web/bundles/ folder is ignored, but some other files in /web folder appear as ignored too. This happened too for /src folder, and adding the !/src sentence to gitignore, although not needed for git, did work for Netbeans. But this solution didn't work for the /web files.

If I check the status of the /web folder using git console, I can see they are not ignored and can be commited, while Netbeans ignores them completely and can not commit the same files.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo