Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 20895 - Cannot remove Compile/Build Actions from FolderNode
Cannot remove Compile/Build Actions from FolderNode
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Data Systems
3.x
All All
: P2 (vote)
: 3.x
Assigned To: Jesse Glick
issues@platform
:
: 24495 (view as bug list)
Depends on: 30138
Blocks: 17815 20894
  Show dependency treegraph
 
Reported: 2002-02-26 16:32 UTC by Petr Hrebejk
Modified: 2008-12-22 09:49 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Hrebejk 2002-02-26 16:32:20 UTC
As the cration of popup menu of FolderNode is hardcoded it is impossible
to remove the actions using xml layers (branding).

It is desirable to read the actions from xml layer.
Comment 1 Jesse Glick 2002-04-14 15:55:13 UTC
Note you can remove them programmatically by getting the data loader
and calling setAction. But that is rather ugly.
Comment 2 Petr Hrebejk 2002-07-09 09:55:38 UTC
*** Issue 24495 has been marked as a duplicate of this issue. ***
Comment 3 Marek Grummich 2002-07-22 11:16:57 UTC
Set target milestone to TBD
Comment 4 Marek Grummich 2002-07-22 11:20:09 UTC
Set target milestone to TBD
Comment 5 Jesse Glick 2002-07-23 01:05:00 UTC
Basically pending Looks, I guess.
Comment 6 David Strupl 2002-07-23 15:14:06 UTC
Part of the new datasystem/actions activities --> target milestone 4.0.
Comment 7 Jesse Glick 2002-10-18 22:11:46 UTC
I will handle this.
Comment 8 Jesse Glick 2002-11-02 21:32:16 UTC
See issue #19443.
Comment 9 Jesse Glick 2002-11-14 23:20:52 UTC
Important parts of #19443 implemented. (Update for planning purposes
only.)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo