Bug 208780 - Profiling Maven NB Platform app does not start
Profiling Maven NB Platform app does not start
Status: RESOLVED DUPLICATE of bug 201132
Product: profiler
Classification: Unclassified
Component: Ide
7.1
PC Mac OS X
: P1 (vote)
: 7.2
Assigned To: issues@profiler
issues@profiler
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-23 09:50 UTC by Tomas Danek
Modified: 2012-02-27 10:25 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2012-02-23 09:50:17 UTC
Product Version: NetBeans IDE 7.1 (Build 201112071828)
Java: 1.6.0_29; Java HotSpot(TM) 64-Bit Server VM 20.4-b02-402
System: Mac OS X version 10.7.3 running on x86_64; MacRoman; en_US (nb)
User directory: /Users/tomas/.netbeans/7.1
Cache directory: /Users/tomas/.netbeans/7.1/var/cache
--------------
- create new maven NB platform app (use release71 bits)
- clean and build parent 
- run "profile" from app project context menu
- profiler does not start, see output log snippet....probably some bad escaping?!

if this is reproducible also on linux && fix is easy and safe, would be nice to have it in 7.1.1



-----------------8<----------------------
[nbm:run-platform]
Executing: /bin/sh -c /tmp/NbApp71/application/target/nbapp71/bin/nbapp71 --userdir /tmp/NbApp71/application/target/userdir -J-Dnetbeans.logger.console=true -J-ea --branding nbapp71 --jdkhome /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home -J-XX:+HeapDumpOnOutOfMemoryError -J-XX:HeapDumpPath=/Users/tomas/.netbeans/7.1/var/cache/mavencachedirs/1945887615/org-netbeans-modules-profiler '-J-agentpath:/Applications/NetBeans/NetBeans -J7.1.app/Contents/Resources/NetBeans/profiler/lib/deployed/jdk16/mac/libprofilerinterface.jnilib=/Applications/NetBeans/NetBeans -J7.1.app/Contents/Resources/NetBeans/profiler/lib,5140,10' --jdkhome /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
Error occurred during initialization of VM
Could not find agent library /Applications/NetBeans/NetBeans -J7.1.app/Contents/Resources/NetBeans/profiler/lib/deployed/jdk16/mac/libprofilerinterface.jnilib in absolute path, with error:  image not found
------------------------------------------------------------------------
BUILD SUCCESS
------------------------------------------------------------------------
Total time: 16.834s
Finished at: Thu Feb 23 10:41:33 CET 2012
Final Memory: 7M/81M
------------------------------------------------------------------------
Comment 1 Tomas Danek 2012-02-23 13:04:39 UTC
confirmed that this is space in path issue..which in unfortunately default case on Mac (What about Windows? C:\Documents and Settings\....) .
Comment 2 Tomas Hurka 2012-02-25 08:04:07 UTC
Is this a regression?
Comment 3 Tomas Danek 2012-02-25 10:35:38 UTC
No, reproducible also in 7.1

(In reply to comment #2)
> Is this a regression?
Comment 4 Tomas Hurka 2012-02-25 19:23:34 UTC
(In reply to comment #3)
> 
> (In reply to comment #2)
> > Is this a regression?
> No, reproducible also in 7.1
This was reported against 7.1. What about 7.0.1?
Comment 5 Tomas Danek 2012-02-25 22:37:17 UTC
Reproducible also in 7.0.1 (Found originally in 7.1.1)
> This was reported against 7.1. What about 7.0.1?
Comment 6 J Bachorik 2012-02-27 07:46:08 UTC
Take a look at http://netbeans.org/bugzilla/show_bug.cgi?id=199922#c13
Comment 7 Tomas Danek 2012-02-27 09:35:43 UTC
so dup of #201132?
Comment 8 Petr Cyhelsky 2012-02-27 10:25:17 UTC

*** This bug has been marked as a duplicate of bug 201132 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo