Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 208681 - Failing tests org.openide.text.CloneableEditorSupportPaneAsyncTest.testGetOpenedPanesAndClose in release71_fixes branch
Failing tests org.openide.text.CloneableEditorSupportPaneAsyncTest.testGetOpe...
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Text
7.1.1
PC Windows XP
: P1 (vote)
: 7.2
Assigned To: Miloslav Metelka
issues@editor
: REGRESSION, TEST
: 203843 211420 211876 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-21 08:22 UTC by Jiri Skrivanek
Modified: 2012-12-18 12:04 UTC (History)
36 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Stack trace from console log. (10.65 KB, text/plain)
2012-02-21 08:22 UTC, Jiri Skrivanek
Details
stacktrace (5.74 KB, text/plain)
2012-03-11 12:11 UTC, Vladimir Voskresensky
Details
stacktrace (5.74 KB, text/plain)
2012-03-11 12:14 UTC, Vladimir Voskresensky
Details
stacktrace (5.02 KB, text/plain)
2012-04-02 12:05 UTC, Martin Fousek
Details
stacktrace (5.00 KB, text/plain)
2012-04-03 06:05 UTC, aws
Details
stacktrace (3.58 KB, text/plain)
2012-04-03 22:02 UTC, Jesse Glick
Details
stacktrace (3.19 KB, text/plain)
2012-04-06 06:41 UTC, williambacchi
Details
stacktrace (3.57 KB, text/plain)
2012-04-06 09:23 UTC, Alexander Simon
Details
stacktrace (3.57 KB, text/plain)
2012-04-06 14:29 UTC, Alexander Simon
Details
stacktrace (5.19 KB, text/plain)
2012-04-06 17:44 UTC, crazyjavahacking
Details
stacktrace (3.19 KB, text/plain)
2012-04-06 19:05 UTC, tbrunhoff
Details
stacktrace (3.58 KB, text/plain)
2012-04-08 08:14 UTC, J Bachorik
Details
stacktrace (5.20 KB, text/plain)
2012-04-10 11:14 UTC, Maksim Khramov
Details
stacktrace (5.19 KB, text/plain)
2012-04-10 14:56 UTC, maghiel
Details
stacktrace (5.12 KB, text/plain)
2012-04-10 19:26 UTC, Martin Fousek
Details
stacktrace (3.58 KB, text/plain)
2012-04-11 01:14 UTC, mrpc
Details
stacktrace (3.58 KB, text/plain)
2012-04-11 15:38 UTC, mrpc
Details
stacktrace (3.58 KB, text/plain)
2012-04-12 06:41 UTC, David Konecny
Details
stacktrace (5.22 KB, text/plain)
2012-04-12 08:53 UTC, J Bachorik
Details
stacktrace (5.20 KB, text/plain)
2012-04-12 11:23 UTC, Vladimir Riha
Details
stacktrace (4.98 KB, text/plain)
2012-04-16 02:38 UTC, misterm
Details
stacktrace (5.20 KB, text/plain)
2012-04-16 11:35 UTC, Vladimir Riha
Details
stacktrace (5.49 KB, text/plain)
2012-04-16 16:29 UTC, paolosca
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2012-02-21 08:22:09 UTC
Created attachment 115974 [details]
Stack trace from console log.

Please, fix failing tests or evaluate problem in code. org.openide.text.CloneableEditorSupportPaneAsyncTest.testGetOpenedPanesAndClose is
failing in release71_fixes branch on windows.

http://hudson4qe.cz.oracle.com/view/NB%207.1%20QE/job/StableBTD-7.1.1/2/testReport
Comment 1 Miloslav Metelka 2012-02-28 14:31:44 UTC
It fails on assertion in CloneableEditor, line 628:

                if (support.cesEnv().isValid()) {
                    assert doc != null;
                }

Since Yarda added that check in terms of issue #180785 I would like to ask Yarda to fix this problem. Thanks in advance.
Comment 2 Marian Mirilovic 2012-02-29 10:36:23 UTC
Yarda, 
we need to fix this ASAP in release71_fixes branch ! 
... as this is a part of test suite provided to JDK team as a part of their certification cycle.
Comment 3 Miloslav Metelka 2012-02-29 11:12:05 UTC
*** Bug 203843 has been marked as a duplicate of this bug. ***
Comment 4 Jaroslav Tulach 2012-02-29 14:44:17 UTC
The test seems to be OK in current trunk version.
Comment 5 Jiri Skrivanek 2012-02-29 15:21:51 UTC
In trunk the same exception occurs randomly not only in tests (see bug 203843). It should be fixed in trunk and test can be disabled in 7.1.1 test distribution.
Comment 6 Jaroslav Tulach 2012-03-01 16:01:15 UTC
Maked randomly failing on the release branch: 8ded17ecdff6
Comment 7 Jaroslav Tulach 2012-03-01 16:05:10 UTC
Passing back to openide/text, as the previous line was: "assert doc != null;" E.g. I have not added the assert. It seems to be introduced when bug 138686 was fixed.
Comment 8 Quality Engineering 2012-03-02 02:55:59 UTC
Integrated into 'releases', will be available in build *201203012225* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/8ded17ecdff6
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #208681: This test seems to fail randomly.
Comment 9 Vladimir Voskresensky 2012-03-11 12:11:17 UTC
Created attachment 116556 [details]
stacktrace

open file
Comment 10 Vladimir Voskresensky 2012-03-11 12:14:18 UTC
Created attachment 116557 [details]
stacktrace

file open
Comment 11 Martin Fousek 2012-04-02 12:05:18 UTC
Created attachment 117652 [details]
stacktrace
Comment 12 aws 2012-04-03 06:05:19 UTC
Created attachment 117711 [details]
stacktrace

when i tried close all tabs ctrl + shift + w
Comment 13 Jesse Glick 2012-04-03 22:02:17 UTC
Created attachment 117762 [details]
stacktrace
Comment 14 Exceptions Reporter 2012-04-03 22:02:26 UTC
This bug already has 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=182064
Comment 15 williambacchi 2012-04-06 06:41:21 UTC
Created attachment 117922 [details]
stacktrace

Closing Project
Comment 16 Alexander Simon 2012-04-06 09:23:20 UTC
Created attachment 117931 [details]
stacktrace

close projects
Comment 17 Alexander Simon 2012-04-06 14:29:21 UTC
Created attachment 117949 [details]
stacktrace
Comment 18 crazyjavahacking 2012-04-06 17:44:22 UTC
Created attachment 117953 [details]
stacktrace

I closed multiple windows using Close all action
Comment 19 tbrunhoff 2012-04-06 19:05:21 UTC
Created attachment 117955 [details]
stacktrace

switching project groups.
Comment 20 J Bachorik 2012-04-08 08:14:23 UTC
Created attachment 117985 [details]
stacktrace

switching project groups
Comment 21 Maksim Khramov 2012-04-10 11:14:23 UTC
Created attachment 118044 [details]
stacktrace
Comment 22 maghiel 2012-04-10 14:56:21 UTC
Created attachment 118071 [details]
stacktrace

Closed all tabs
Comment 23 Miloslav Metelka 2012-04-10 15:12:40 UTC
I'm unable to reproduce the problem. I assume that the trunk has the same problem.
I've attempted to store the document instance (being loaded) earlier in the prepareTask (at time of its construction). I would like to ask reporters to test whether the fix helped or not. Thanks.

http://hg.netbeans.org/jet-main/rev/5192321f3ac2
Comment 24 Martin Fousek 2012-04-10 19:26:24 UTC
Created attachment 118084 [details]
stacktrace

ctrl + shift + w for closing all opened tabs
Comment 25 mrpc 2012-04-11 01:14:24 UTC
Created attachment 118093 [details]
stacktrace

Started up netbeans, and tried to close a project (right click on project on projects window -> close)
Comment 26 Exceptions Reporter 2012-04-11 08:05:24 UTC
This bug already has 50 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=182064
Comment 27 mrpc 2012-04-11 15:38:23 UTC
Created attachment 118144 [details]
stacktrace

Closed some projects
Comment 28 David Konecny 2012-04-12 06:41:24 UTC
Created attachment 118169 [details]
stacktrace
Comment 29 David Konecny 2012-04-12 06:47:10 UTC
It just happened to me on the latest dev build which contains your fix.
Comment 30 J Bachorik 2012-04-12 08:53:23 UTC
Created attachment 118180 [details]
stacktrace

selected close all
Comment 31 Quality Engineering 2012-04-12 09:59:54 UTC
Integrated into 'main-golden', will be available in build *201204120400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/5192321f3ac2
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #208681 - Failing tests org.openide.text.CloneableEditorSupportPaneAsyncTest.testGetOpenedPanesAndClose.
Comment 32 Vladimir Riha 2012-04-12 11:23:24 UTC
Created attachment 118191 [details]
stacktrace

Close All on files from already closed projects
Comment 33 misterm 2012-04-16 02:38:25 UTC
Created attachment 118296 [details]
stacktrace
Comment 34 Miloslav Metelka 2012-04-16 08:31:05 UTC
Second attempt to fix the problem:
http://hg.netbeans.org/jet-main/rev/6651b7c6907b
Comment 35 Vladimir Riha 2012-04-16 11:35:23 UTC
Created attachment 118323 [details]
stacktrace

closing all opened editor windows durign startup scanning
Comment 36 paolosca 2012-04-16 16:29:25 UTC
Created attachment 118355 [details]
stacktrace

Closed a php file
Comment 37 Quality Engineering 2012-04-17 10:03:23 UTC
Integrated into 'main-golden', will be available in build *201204170400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/6651b7c6907b
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #208681 - Failing tests org.openide.text.CloneableEditorSupportPaneAsyncTest.testGetOpenedPanesAndClose - stop further processing when another thread would call CES.closeDocument().
Comment 38 Miloslav Metelka 2012-04-20 14:57:14 UTC
*** Bug 211420 has been marked as a duplicate of this bug. ***
Comment 39 Jiri Skrivanek 2012-04-26 13:27:28 UTC
Verified. The test is passing and I haven't seen this exception in IDE anymore.
Comment 40 David Strupl 2012-12-18 12:04:16 UTC
*** Bug 211876 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo