Bug 208652 - Infinite loop in DirectMergeContainer
Infinite loop in DirectMergeContainer
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Painting & Printing
7.2
PC All
: P3 (vote)
: 7.2
Assigned To: Miloslav Metelka
issues@editor
:
: 208487 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-20 15:43 UTC by Miloslav Metelka
Modified: 2012-02-22 11:03 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miloslav Metelka 2012-02-20 15:43:20 UTC
Based on issue #154019 it can be reproduced by
1. Create PHP project
2. Create a new PHP file
3. Select All text
4. Paste the following text
<?
class Form {
    function add_text_field() {}
    function add_listbox() {}
}
?>
5. Invoke Alt+Shift+F for reformat.
6. CPU at 100% due to infinite loop in DirectMergeContainer.
Comment 1 Miloslav Metelka 2012-02-20 15:45:37 UTC
http://hg.netbeans.org/jet-main/rev/e4f2e2e42ab6
Comment 2 Miloslav Metelka 2012-02-20 15:47:21 UTC
*** Bug 208487 has been marked as a duplicate of this bug. ***
Comment 3 Quality Engineering 2012-02-21 10:56:22 UTC
Integrated into 'main-golden', will be available in build *201202210400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/e4f2e2e42ab6
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #208652 - Infinite loop in DirectMergeContainer.
Comment 4 Quality Engineering 2012-02-22 11:03:37 UTC
Integrated into 'main-golden', will be available in build *201202220400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/e4f2e2e42ab6
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #208652 - Infinite loop in DirectMergeContainer.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo