Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 208638 - "Find usages" limited to one search
"Find usages" limited to one search
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Refactoring
7.1
PC Linux
: P4 with 1 vote (vote)
: 7.2
Assigned To: Ralph Ruijs
issues@editor
: UI, USABILITY
: 211690 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-20 11:50 UTC by ucho
Modified: 2012-04-25 10:21 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ucho 2012-02-20 11:50:44 UTC
It seems that functionality added in #15728 was removed - Netbeans now displays only the result of last "find usages". Is this intentional change?
Comment 1 Jaroslav Havlin 2012-02-20 12:02:37 UTC
Did you check the "Open in New Tab" checkbox at the bottom left corner of the "Find Usages" dialog?
Comment 2 ucho 2012-02-20 13:01:19 UTC
Shouldn't it be enabled by default to be consistent with old behavior?
Comment 3 Jaroslav Havlin 2012-02-20 13:06:06 UTC
I'm sorry, but I'm not sure. Reassigning to more appropriate component.
Comment 4 Ralph Ruijs 2012-02-20 14:18:13 UTC
#15728 is specifically about the find in projects feature. #103720 implemented the reuse tab checkbox, and I agree with the current implementation. Added Petr and Jarda to CC, as this needs some more evaluation about what should be the standard behaviour.
Comment 5 Petr Somol 2012-02-23 12:16:02 UTC
this issue affects more than just Find usages, for more info see

wiki.netbeans.org/UEXTabReuse
Comment 6 Ralph Ruijs 2012-04-25 08:57:01 UTC
Fixed in jet-main #7b978c92c683
Comment 7 Ralph Ruijs 2012-04-25 10:21:24 UTC
*** Bug 211690 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo