Bug 208353 - LowPerformance took 180283 ms.
LowPerformance took 180283 ms.
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Project
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Alexander Simon
issues@cnd
EXCEPTIONS_REPORT perf-profileme, 701...
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-13 15:10 UTC by stiffuser
Modified: 2012-04-26 14:58 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (2.53 MB, application/nps)
2012-02-13 15:11 UTC, stiffuser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stiffuser 2012-02-13 15:10:28 UTC
Build: NetBeans IDE Dev (Build nbms-and-javadoc-8678-on-20120209)
VM: Java HotSpot(TM) 64-Bit Server VM, 22.0-b10, Java(TM) SE Runtime Environment, 1.7.0_02-b13
OS: Windows 7

User Comments:
stiffuser: This is a large project that includes a lot of files on a network drive. Every time I open it, the IDE hangs for *minutes*. Why does doing all this I/O have to happen on the GUI thread?



Maximum slowness yet reported was 180283 ms, average is 100860
Comment 1 stiffuser 2012-02-13 15:11:17 UTC
Created attachment 115668 [details]
nps snapshot
Comment 2 igor_nikiforov 2012-02-14 09:54:07 UTC
Looks like a regression introduced by Bug 196885 "New C source file doesn't show in Project view" fix.

The method MakeConfigurationDescriptor.findItemByPathSlowly should not be used from the UI thread. Probably this method should not be public at all.
Comment 3 Alexander Simon 2012-04-24 14:53:02 UTC
fixed, change set:
http://hg.netbeans.org/cnd-main/rev/d61ab8ddcd1a

It seems it was typo during fixing the bug #196885.
Comment 4 Quality Engineering 2012-04-25 09:59:09 UTC
Integrated into 'main-golden', will be available in build *201204250400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/d61ab8ddcd1a
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #208353 LowPerformance took 180283 ms.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo