Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 208332 - Support Git submodules
Support Git submodules
Status: RESOLVED DUPLICATE of bug 207067
Product: versioncontrol
Classification: Unclassified
Component: Git
7.1
All All
: P1 (vote)
: TBD
Assigned To: Ondrej Vrabec
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-13 12:20 UTC by Tomas Mysik
Modified: 2012-02-13 13:07 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2012-02-13 12:20:56 UTC
Please, add support for Git submodules [1][2]. I can provide more information or even sample repo if needed.

The current state is:
- submodule files look like new files (green highlighting)

I did not try to commit or whatever from the IDE since I am not sure what would happen :)

Thanks.
[1] http://progit.org/book/ch6-6.html
[2] http://book.git-scm.com/5_submodules.html
Comment 1 Ondrej Vrabec 2012-02-13 12:35:45 UTC
same as #207067, the reason for incorrect statuses and failing commands is that .git in submodules is not a folder but a text file with link to the actual .git metadata folder. Our Git support is unable to parse it.

*** This bug has been marked as a duplicate of bug 207067 ***
Comment 2 jessholle 2012-02-13 13:07:33 UTC
As per comments on the other bug, a .git file of this form is a standard layout supported by and in cases automatically chosen by Git.  Saying NetBeans' Git module cannot support this it is equivalent of saying that the NetBeans Git support is committed to being broken!


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo