Bug 208322 - [71cat] NullPointerException at org.netbeans.modules.versioning.core.api.VCSFileProxy.createFileProxy
[71cat] NullPointerException at org.netbeans.modules.versioning.core.api.VCSF...
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Code
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Tomas Stupka
issues@versioncontrol
EXCEPTIONS_REPORT
:
: 209334 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-13 09:58 UTC by schkovich
Modified: 2012-03-09 17:33 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.52 KB, text/plain)
2012-02-13 09:58 UTC, schkovich
Details
stacktrace (1.52 KB, text/plain)
2012-02-13 11:45 UTC, paolosca
Details
stacktrace (1.52 KB, text/plain)
2012-02-13 14:09 UTC, schkovich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description schkovich 2012-02-13 09:58:25 UTC
Build: NetBeans IDE Dev (Build 201202120400)
VM: Java HotSpot(TM) 64-Bit Server VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Linux

User Comments:
schkovich: Commiting changes to the repository




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.versioning.core.api.VCSFileProxy.createFileProxy(VCSFileProxy.java:95)
   at org.netbeans.modules.versioning.DelegatingVCS.toProxies(DelegatingVCS.java:653)
   at org.netbeans.modules.versioning.DelegatingVCS.access$200(DelegatingVCS.java:72)
   at org.netbeans.modules.versioning.DelegatingVCS$DelegatingHistoryProvider$DelegateChangeListener.fireHistoryChanged(DelegatingVCS.java:621)
   at org.netbeans.modules.subversion.HistoryProvider$1.run(HistoryProvider.java:159)
   at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1404)
Comment 1 schkovich 2012-02-13 09:58:28 UTC
Created attachment 115643 [details]
stacktrace
Comment 2 paolosca 2012-02-13 11:45:56 UTC
Created attachment 115648 [details]
stacktrace

Did nothing, I switched to a different window (to type an email) and when I focused back to NetBeans the error was there.
Comment 3 Tomas Stupka 2012-02-13 13:08:04 UTC
fixed in #8ebe91b2e5df
Comment 4 schkovich 2012-02-13 14:09:57 UTC
Created attachment 115665 [details]
stacktrace

Commiting changes to the repository. Existing bug is marked as fixed. Once fix becomes available in the devlopment builds I will verify it.
Comment 5 Tomas Stupka 2012-03-09 17:33:00 UTC
*** Bug 209334 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo