Bug 208201 - NullPointerException on start of application based on RCP
NullPointerException on start of application based on RCP
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Autoupdate
7.2
All All
: P2 (vote)
: 7.2
Assigned To: Jiri Rechtacek
au-issues
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-09 15:04 UTC by Vladimir Voskresensky
Modified: 2012-10-18 02:05 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Voskresensky 2012-02-09 15:04:44 UTC
[exec] WARNING [org.netbeans.modules.autoupdate.ui.actions.AutoupdateSettings]: The property "netbeans.default_userdir_root" was not set!
     [exec] SEVERE [org.netbeans.core.modules]
     [exec] java.lang.NullPointerException
     [exec]     at java.io.FileOutputStream.<init>(FileOutputStream.java:186)
     [exec]     at java.io.FileOutputStream.<init>(FileOutputStream.java:145)
     [exec]     at java.io.FileWriter.<init>(FileWriter.java:73)
     [exec]     at org.netbeans.modules.autoupdate.ui.actions.AutoupdateSettings.writeSuperFile(AutoupdateSettings.java:380)
     [exec]     at org.netbeans.modules.autoupdate.ui.actions.AutoupdateSettings.getSuperFile(AutoupdateSettings.java:357)
     [exec]     at org.netbeans.modules.autoupdate.ui.actions.AutoupdateSettings.getSuperIdentity(AutoupdateSettings.java:429)
     [exec]     at org.netbeans.modules.autoupdate.ui.actions.AutoupdateSettings.generateIdentity(AutoupdateSettings.java:136)
     [exec]     at org.netbeans.modules.autoupdate.ui.actions.AutoupdateCheckScheduler.signOn(AutoupdateCheckScheduler.java:111)
     [exec]     at org.netbeans.modules.autoupdate.ui.actions.Installer.restored(Installer.java:63)
     [exec]     at org.netbeans.core.startup.NbInstaller.loadCode(NbInstaller.java:422)
     [exec] [catch] at org.netbeans.core.startup.NbInstaller.load(NbInstaller.java:362)
     [exec]     at org.netbeans.ModuleManager.enable(ModuleManager.java:1096)
     [exec]     at org.netbeans.ModuleManager.enable(ModuleManager.java:906)
     [exec]     at org.netbeans.core.startup.ModuleList.installNew(ModuleList.java:340)
     [exec]     at org.netbeans.core.startup.ModuleList.trigger(ModuleList.java:276)
     [exec]     at org.netbeans.core.startup.ModuleSystem.restore(ModuleSystem.java:294)
     [exec]     at org.netbeans.core.startup.Main.getModuleSystem(Main.java:167)
     [exec]     at org.netbeans.core.startup.Main.start(Main.java:303)
     [exec]     at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:123)
     [exec]     at java.lang.Thread.run(Thread.java:662)
Comment 1 Vladimir Voskresensky 2012-02-09 15:21:41 UTC
looks like it is related to issue #207502
Comment 2 Jiri Rechtacek 2012-02-09 15:31:26 UTC
Vladimir, could you send me build number? Is it a build from deadlock or custom build? I've fixed it and it's looks as a regression. Thanks
Comment 3 Vladimir Voskresensky 2012-02-09 15:44:59 UTC
Jiri, I will send you private mail with link 
unpack studio-ide.tar.bz2 and run bin/solstudio => you will see exception
Comment 4 Jiri Rechtacek 2012-02-09 19:32:32 UTC
Thank you for catching this.

core-main/rev/581d23afe00f
Comment 5 Quality Engineering 2012-10-18 02:05:33 UTC
Integrated into 'main-golden', will be available in build *201210180002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/e2ae199b42a9
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #208201 - NPE on start of application based on RCP


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo