Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 208078 - Text limit line regression
Text limit line regression
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Painting & Printing
7.1
PC Mac OS X
: P3 (vote)
: 7.3
Assigned To: Miloslav Metelka
issues@editor
:
Depends on: 205707
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-06 10:00 UTC by emi
Modified: 2016-07-07 07:31 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Correct text limit line in 6.8 (67.57 KB, image/png)
2012-02-06 10:00 UTC, emi
Details
Incorrect limit line in 7.1 (86.39 KB, image/png)
2012-02-06 10:01 UTC, emi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description emi 2012-02-06 10:00:48 UTC
Created attachment 115484 [details]
Correct text limit line in 6.8

It seems the text limit line doesn't paint over the whole editor area anymore, only over the text lines.

So on a file with only a few lines the limit line just looks odd and unfinished.

This seemed to work ok in NetBeans 6.8 but not in 7.1 (and neither in 7.0.1 actually).

See attached screenshots.

I'll link this bugreport with this older one (#122859) from 6.0 that looks similar (but seems odd since in 6.8 I don't see it).

Also linking to #205707 which is the umbrella report for the new painting architecture.
Comment 1 emi 2012-02-06 10:01:21 UTC
Created attachment 115485 [details]
Incorrect limit line in 7.1
Comment 2 Miloslav Metelka 2012-06-07 11:58:16 UTC
Yes the extra area below document end is currently not painted.
Comment 3 Martin Balin 2016-07-07 07:31:27 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo