Bug 207994 - Proxy By-Pass List Ignored, Deployment to localhost prevented.
Proxy By-Pass List Ignored, Deployment to localhost prevented.
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: WebLogic
7.3
PC Windows 7
: P3 (vote)
: 7.3.1
Assigned To: Petr Hejl
issues@serverplugins
73patch2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-01 17:18 UTC by chase
Modified: 2013-05-09 13:59 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (13.05 KB, text/plain)
2013-04-04 04:32 UTC, chase
Details

Note You need to log in before you can comment on or make changes to this bug.
Description chase 2012-02-01 17:18:50 UTC
Running JDK 7u2, WebLogic 12c Developer Zip, and NetBeans 7.1 on Windows 2003.

The system is running in a classroom environment with restricted internet access and a proxy server. The proxy settings have a by-pass/override list which includes both localhost and 127.0.0.1.

Web browsers correctly use the by-pass list.

When NetBeans is left at it's default "Use System Proxy Settings" enterprise applications (tested with a basic hello world war) can not be deployed to the local WebLogic install from within NetBeans.

The output includes a very long stack trace, the relevant info:
Caused by: javax.naming.CommunicationException [Root exception is java.net.ConnectException: t3://localhost:7001: Destination unreachable; nested exception is:
    java.net.ProtocolException: unrecognized response from proxy: 'HTTP/1.0 403 Forbidden'; No available router to destination]

Also, the WebLogic node within the servers tab can not be expanded to show the resources and applications.

Command line and Web based WebLogic administration tasks function correctly.

Changing NetBean's proxy settings to "No Proxy" solves all WebLogic issues but prevents access to those sites reached by the proxy server. For example, showing the JavaDocs for JDK7 no longer works because it looks like NetBeans tries to detect the presence of the docs at the JavaDoc URL location before launching the web browser.
Comment 1 Petr Hejl 2012-04-04 10:07:22 UTC
Should be fixed. Please verify.
web-main 57d2add0b22b and 9a872a5489c6
Comment 2 Quality Engineering 2012-04-05 09:39:05 UTC
Integrated into 'main-golden', will be available in build *201204050400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/57d2add0b22b
User: Petr Hejl <phejl@netbeans.org>
Log: #207994 Proxy By-Pass List Ignored, Deployment to localhost prevented.
Comment 3 chase 2013-04-04 04:30:37 UTC
Reopening, the problem still happens in Oracle University classrooms with jdk1.7.0_17 and NB 7.3. Changing the proxy setting to make WLS deployment function breaks all internet related communication such as automatic XML schema download.
Comment 4 chase 2013-04-04 04:32:59 UTC
Created attachment 133291 [details]
stacktrace
Comment 5 Petr Hejl 2013-04-04 06:07:45 UTC
I have no idea how this could happen. Can you share the server startup log? Especially startup parameters? Thanks.
Comment 6 chase 2013-04-04 09:24:10 UTC
I don't think it is related to server startup. I figured out that I can get everything working if I set Netbeans to Manual Proxy Settings, go to More, and add localhost to the No Proxy Hosts field.

Using jVisualVM I noticed that with my fully working manual config I have:
http.nonProxyHosts=localhost
https.nonProxyHosts=localhost
system properties in my NetBeans VM.

When Use System Proxy Settings is used I'm missing http.nonProxyHosts and https.nonProxyHosts system properties even though netbeans.system_http_non_proxy_hosts=localhost is there.
Comment 7 Petr Hejl 2013-04-04 10:31:11 UTC
I've tried to fix that in web-main dbe0558c7485. Could you please test that with upcoming build number 10241 from http://bertram2.netbeans.org:8080/job/web-main/ ?
Thanks.
Comment 8 chase 2013-04-04 21:20:20 UTC
Build 10242 seems to work. I can deploy to WLS and create XML schema constrained documents with web accessible schemas now. Thanks!
Comment 9 Petr Hejl 2013-04-04 21:22:09 UTC
Ok, closing as fixed. Thanks for your help.
Comment 10 Petr Hejl 2013-04-05 13:53:55 UTC
Transplanted also to javaee7 722023fd9b6d.
Comment 11 Jiri Skrivanek 2013-04-16 13:35:41 UTC
Verified by reporter.
Comment 12 Marian Mirilovic 2013-05-03 11:14:52 UTC
So, where exactly is this issue fixed ? Is it already in release73 repository ?
If so, please change SW to '73patch2-fixed',
If not, please backport the fix into release73 ASAP 

Thanks in advance.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo