Bug 207690 - AssertionError: nbfs://nbhost//
AssertionError: nbfs://nbhost//
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Filesystems
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Jesse Glick
issues@platform
EXCEPTIONS_REPORT
:
: 207701 207757 (view as bug list)
Depends on: 39613
Blocks: 207294
  Show dependency treegraph
 
Reported: 2012-01-24 15:10 UTC by mklaehn
Modified: 2012-02-06 11:19 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.04 KB, text/plain)
2012-01-24 15:10 UTC, mklaehn
Details
log from 201201260600 (118.55 KB, text/plain)
2012-01-27 15:28 UTC, Stepan Zebra
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mklaehn 2012-01-24 15:10:27 UTC
Build: NetBeans IDE Dev (Build nbms-and-javadoc-8570-on-20120122)
VM: Java HotSpot(TM) Server VM, 20.1-b02, Java(TM) SE Runtime Environment, 1.6.0_26-b03
OS: Windows XP

User Comments:
mklaehn: The AssertionError happened after deleting the folder structure of a project outside of NB (Windows Explorer). The AssertionError is so dominant that i can only use the Exception Reporter after all Errors have been raised.

Closing NB while deleting the folders does not help either. The errors are then raised during restart/opening of projects.




Stacktrace: 
java.lang.AssertionError: nbfs://nbhost//
   at org.openide.filesystems.FileObject.toURI(FileObject.java:1165)
   at org.netbeans.modules.projectapi.SimpleFileOwnerQueryImplementation.getOwner(SimpleFileOwnerQueryImplementation.java:168)
   at org.netbeans.api.project.FileOwnerQuery.getOwner(FileOwnerQuery.java:104)
   at org.netbeans.modules.refactoring.java.RefactoringUtils.isOnSourceClasspath(RefactoringUtils.java:289)
   at org.netbeans.modules.refactoring.java.api.JavaRefactoringUtils.isOnSourceClasspath(JavaRefactoringUtils.java:88)
   at org.netbeans.modules.refactoring.java.ui.RefactoringActionsProvider.canCopy(RefactoringActionsProvider.java:398)
Comment 1 mklaehn 2012-01-24 15:10:30 UTC
Created attachment 115191 [details]
stacktrace
Comment 2 Jesse Glick 2012-01-24 23:19:59 UTC
Similar to bug #207648 but I think a different code path.
Comment 3 Jesse Glick 2012-01-25 00:12:10 UTC
core-main #ac372707e0e6
Comment 4 Jesse Glick 2012-01-25 19:56:49 UTC
*** Bug 207701 has been marked as a duplicate of this bug. ***
Comment 5 Quality Engineering 2012-01-26 16:11:31 UTC
Integrated into 'main-golden', will be available in build *201201260600* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/ac372707e0e6
User: Jesse Glick <jglick@netbeans.org>
Log: #207690: AssertionError: nbfs://nbhost//
URLs created for files on the system filesystem were syntactically malformed and could not be used as URIs.
Using nbfs://nbhost/SystemFileSystem/<path> (as in older releases?) seems to help.
Also have to properly escape path components; URLEncoder is only for x-www-form-urlencoded, not URLs/URIs!
Comment 6 Jesse Glick 2012-01-26 19:28:19 UTC
*** Bug 207757 has been marked as a duplicate of this bug. ***
Comment 7 Stepan Zebra 2012-01-27 15:28:51 UTC
Created attachment 115323 [details]
log from 201201260600

I'm getting a lot of these errors in 201201260600 on Windows machines, when I crate a new Mobile Application Project.
Comment 8 Jesse Glick 2012-01-27 17:14:54 UTC
Not sure, I fixed the obvious cause for this error and wrote a test for it. Adding additional assertions which should help diagnose if it continues to happen in newer dev builds.
Comment 9 Jesse Glick 2012-01-27 19:42:33 UTC
core-main #5a959d1133bc might fix it.
Comment 10 Stepan Zebra 2012-01-30 08:08:37 UTC
(In reply to comment #9)
> core-main #5a959d1133bc might fix it.

No more errors for me after this, thanks.
Comment 11 mklaehn 2012-02-06 11:19:14 UTC
Haven't had that error anymore, thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo