Bug 207632 - NPE from profiled application during Stop profiling
NPE from profiled application during Stop profiling
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Engine
7.1
PC Windows 7
: P3 (vote)
: 7.3
Assigned To: Tomas Hurka
issues@profiler
: VISUALVM
: 200273 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-23 14:51 UTC by Jiri Sedlacek
Modified: 2012-11-15 02:48 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Sedlacek 2012-01-23 14:51:45 UTC
Product Version: NetBeans IDE Dev (Build 20120123-de5ca11607e2)
Java: 1.6.0_30; Java HotSpot(TM) 64-Bit Server VM 20.5-b03
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)

Steps:

 1/ Started profiling AnagramGame, CPU, Profile application, default roots, Profile all classes
 2/ Didn't open Live Results, clicked Stop profiling icon in Profiler Control Panel shortly after starting the profiling session

The following exception has been thrown into profiled app Output. Probably not easily reproducible. Profiling session has been terminated correctly, profiled application has been stopped.

Exception in thread "main" java.lang.NullPointerException
	at org.netbeans.lib.profiler.server.ProfilerRuntimeCPU.copyLocalBuffer(ProfilerRuntimeCPU.java:273)
	at org.netbeans.lib.profiler.server.ProfilerRuntimeCPU.writeTimeStampedEvent(ProfilerRuntimeCPU.java:499)
	at org.netbeans.lib.profiler.server.ProfilerRuntimeCPUFullInstr.methodExit(ProfilerRuntimeCPUFullInstr.java:212)
	at java.util.HashMap.get(HashMap.java:308)
	at com.sun.java.swing.plaf.nimbus.NimbusStyle.compileDefaults(NimbusStyle.java:383)
	at com.sun.java.swing.plaf.nimbus.NimbusStyle.validate(NimbusStyle.java:301)
	at com.sun.java.swing.plaf.nimbus.NimbusStyle.getValues(NimbusStyle.java:928)
	at com.sun.java.swing.plaf.nimbus.NimbusStyle.getInsets(NimbusStyle.java:607)
	at javax.swing.plaf.synth.SynthStyle.installDefaults(SynthStyle.java:896)
	at javax.swing.plaf.synth.SynthLookAndFeel.updateStyle(SynthLookAndFeel.java:277)
	at javax.swing.plaf.synth.SynthPanelUI.updateStyle(SynthPanelUI.java:71)
	at javax.swing.plaf.synth.SynthPanelUI.installDefaults(SynthPanelUI.java:58)
	at javax.swing.plaf.basic.BasicPanelUI.installUI(BasicPanelUI.java:40)
	at javax.swing.plaf.synth.SynthPanelUI.installUI(SynthPanelUI.java:39)
	at javax.swing.JComponent.setUI(JComponent.java:665)
	at javax.swing.JPanel.setUI(JPanel.java:137)
	at javax.swing.JPanel.updateUI(JPanel.java:110)
	at javax.swing.JPanel.<init>(JPanel.java:70)
	at javax.swing.JPanel.<init>(JPanel.java:93)
	at javax.swing.JPanel.<init>(JPanel.java:101)
	at javax.swing.JRootPane.createGlassPane(JRootPane.java:529)
	at javax.swing.JRootPane.<init>(JRootPane.java:349)
	at javax.swing.JFrame.createRootPane(JFrame.java:260)
	at javax.swing.JFrame.frameInit(JFrame.java:237)
	at javax.swing.JFrame.<init>(JFrame.java:160)
	at com.toy.anagrams.ui.Anagrams.<init>(Anagrams.java:78)
	at com.toy.anagrams.ui.Anagrams.main(Anagrams.java:71)
Comment 1 Tomas Hurka 2012-11-08 10:36:34 UTC
*** Bug 200273 has been marked as a duplicate of this bug. ***
Comment 2 Tomas Hurka 2012-11-08 11:52:01 UTC
Hopefully fixed in profiler-main

changeset:   238600:b74fb5f26d4c
user:        Tomas Hurka <thurka@netbeans.org>
date:        Thu Nov 08 12:50:41 2012 +0100
summary:     bugfix #207632, make sure eventBuffer is still valid
Comment 3 Quality Engineering 2012-11-15 02:48:48 UTC
Integrated into 'main-golden', will be available in build *201211150001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/b74fb5f26d4c
User: Tomas Hurka <thurka@netbeans.org>
Log: bugfix #207632, make sure eventBuffer is still valid


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo