Bug 207611 - 10s - org.openide.loaders.MultiDataObject$Entry.takeLock()
10s - org.openide.loaders.MultiDataObject$Entry.takeLock()
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Data Systems
7.2
All All
: P3 (vote)
: 7.4
Assigned To: Jaroslav Havlin
issues@platform
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 227455 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-23 08:12 UTC by williambacchi
Modified: 2013-08-21 06:54 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (20.99 KB, application/nps)
2012-01-23 08:13 UTC, williambacchi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description williambacchi 2012-01-23 08:12:55 UTC
Build: NetBeans IDE Dev (Build 201201180601)
VM: Java HotSpot(TM) Client VM, 17.1-b03, Java(TM) SE Runtime Environment, 1.6.0_22-b04
OS: Windows XP

User Comments:
GUEST: copy/paste

williambacchi: pasting code

GUEST: Scrolling through my document. Is netbeans fighting with TSVNCache.exe?

gedrox: Did SVN update



Maximum slowness yet reported was 10562 ms, average is 5885
Comment 1 williambacchi 2012-01-23 08:13:03 UTC
Created attachment 115153 [details]
nps snapshot
Comment 2 Jaroslav Tulach 2012-01-26 08:32:42 UTC
The attempt to lock the document:
org.openide.loaders.MultiDataObject$Entry.takeLock()	99.799736	10418 ms (99,8%)	10418 ms	1
is blocked by 
java.io.File.canWrite()	99.799736	10418 ms (99,8%)	10418 ms	1


There is intensive parsing running on background:
org.netbeans.modules.tasklist.todo.TodoTaskScanner.getContent()	100.0	10439 ms (100%)	10439 ms	1

I have no idea what to do with this problem.
Comment 3 Alexander Simon 2013-01-29 10:39:50 UTC
A lot of new reports.
Please reevaluate issue.
I do not understand why IO operations in EDT => do not fix
Comment 4 Jaroslav Tulach 2013-07-18 06:40:13 UTC
I will use ProgressUtils.runOffEDT in DataEditorSupport.Env.markModified
Comment 5 Jaroslav Tulach 2013-07-18 07:52:58 UTC
ergonomics#0cc454c2ea51
Comment 6 Quality Engineering 2013-07-20 02:10:23 UTC
Integrated into 'main-silver', will be available in build *201307192300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/0cc454c2ea51
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #207611: Show runOffEDT dialog in case the I/O takes more than 3s and allow user to cancel the operation.
Comment 7 Jaroslav Havlin 2013-08-21 06:54:33 UTC
*** Bug 227455 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo