Bug 207579 - When updating or import plugins Netbeans asks to restart now or later if restart now is chosen it would not restart Automatically i have to click the shortcut to start Netabeans again so that update takes effect
When updating or import plugins Netbeans asks to restart now or later if rest...
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Launchers&CLI
7.1
PC Windows 7
: P1 with 2 votes (vote)
: 7.3
Assigned To: Libor Fischmeistr
issues@platform
: RELNOTE
: 213976 219239 219252 220747 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-20 16:36 UTC by giorgoch
Modified: 2012-10-25 11:52 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
netbeans launcher's log (95.31 KB, text/plain)
2012-04-20 13:30 UTC, Jiri Rechtacek
Details
Update log (27.77 KB, text/plain)
2012-04-20 22:54 UTC, javydreamercsw
Details
Restart log (51.98 KB, text/plain)
2012-04-20 22:54 UTC, javydreamercsw
Details
Launcher DLL - additional logging (418.16 KB, application/x-msdownload)
2012-04-23 14:48 UTC, Libor Fischmeistr
Details
Enhanced Update log (39.89 KB, text/plain)
2012-04-23 17:25 UTC, javydreamercsw
Details
Enhanced Restart log (33.13 KB, text/plain)
2012-04-23 17:25 UTC, javydreamercsw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description giorgoch 2012-01-20 16:36:14 UTC
Product Version = NetBeans IDE 7.1 (Build 201112071828)
Operating System = Windows 7 version 6.1 running on x86
Java; VM; Vendor = 1.6.0_26
Runtime = Java HotSpot(TM) Client VM 20.1-b02
Comment 1 javydreamercsw 2012-02-17 18:04:00 UTC
Same behavior on 7.1.1. I'm also on Windows 7, maybe issue is related to that?
Comment 2 Jiri Rechtacek 2012-02-22 15:51:16 UTC
  Product Version         = NetBeans IDE 7.1 (Build 201201092359) (#216a3a96782e)
  Operating System        = Windows 7 version 6.1 running on amd64
  Java; VM; Vendor        = 1.6.0_30; Java HotSpot(TM) 64-Bit Server VM 20.5-b03; Sun Microsystems Inc.
  Runtime                 = Java(TM) SE Runtime Environment 1.6.0_30-b12
  Java Home               = C:\Program Files\Java\jdk1.6.0_30\jre
  System Locale; Encoding = en_US (nb); Cp1252

Works for me on my machine. Is there anything platform (32bit vs. 64bit) specific? Have you tried with different JDK (latest JDK6, JDK&)? Thanks
Comment 3 javydreamercsw 2012-02-22 18:06:40 UTC
Here's my info:

Product Version: NetBeans IDE Dev (Build 201202140400)
Java: 1.7.0_03; Java HotSpot(TM) Client VM 22.1-b02
System: Windows 7 version 6.1 running on x86; Cp1252; en_US (nb)

Same behavior with JDK 6 or JDK 7.
Comment 4 Jiri Rechtacek 2012-04-18 15:33:03 UTC
I guess the problem was caused by mixing 32-bit JRE on x64 platform (or otherwise). It was fixed in 7.2 by providing 64-bit launchers on x64 Windows. Could you verify it works correctly on recent builds of IDE (Note: NetBeans installer is responsible for choosing the right launcher according to Windows platform)? Thanks
Comment 5 javydreamercsw 2012-04-18 16:48:42 UTC
I still
Comment 6 javydreamercsw 2012-04-18 16:50:17 UTC
This still happens for me on 7.1.2 (NetCat) and daily builds. I'm running on JDK 7 32 bit using the zip distribution. So I doubt is 64 bit specific.
Comment 7 Jiri Rechtacek 2012-04-19 09:55:56 UTC
(In reply to comment #6)
> This still happens for me on 7.1.2 (NetCat) and daily builds. I'm running on
> JDK 7 32 bit using the zip distribution. So I doubt is 64 bit specific.

That's the problem, you are running JDK7 32-bit on 64-bit Windows. Run netbeans64.exe instead of netbeans.exe on recent Dev builds and let me know it's still reproducible of not. Thanks
Comment 8 javydreamercsw 2012-04-19 13:13:42 UTC
I'm running on JDK 7 32 bit using the zip distribution. My Windows 7 is 32 bits, what's wrong with that?
Comment 9 Jiri Rechtacek 2012-04-19 13:20:59 UTC
(In reply to comment #8)
> I'm running on JDK 7 32 bit using the zip distribution. My Windows 7 is 32
> bits, what's wrong with that?
Sorry I thought you are running on 64-bit Windows.
Comment 10 Jiri Rechtacek 2012-04-19 13:25:38 UTC
Anyway I cannot reproduce it on my Windows 7. In that case the only way what I can do is add some logging around code which invokes restart IDE and ask you to send back your log to allow me detect a possible problem. I let you know once such logging is available.
Comment 11 Jiri Rechtacek 2012-04-20 09:03:52 UTC
(In reply to comment #6)
> This still happens for me on 7.1.2 (NetCat) and daily builds. I'm running on
> JDK 7 32 bit using the zip distribution. So I doubt is 64 bit specific.

Allow me restate my understanding the problem:
1) Install NB7.1 [*] with empty userdir
2) Invoke Tools|Plugins and install available plugins
3) Chose Restart Now on the last page in Plugins Installation Wizard
4) IDE quits but _doesn't start again_ automatically
5) On start IDE manually the Updater splash will be shown and then IDE starts normally

Did I missed anything? Could you confirm that these steps (without any modification) can reproduce the problem? Thanks in advance

[*] http://netbeans.org/downloads/7.1/
Comment 12 javydreamercsw 2012-04-20 11:30:15 UTC
That's correct. In my case there are 2 environment conditions that might come into play:
1) JDK and NetBeans are installed in USB (zip distro)
2) I don't remember if I select restart in the last wizard page. I know for sure it doesn't happen when using the icon in the task bar. It shouldn't matter but just in case.
Comment 13 Jiri Rechtacek 2012-04-20 13:30:32 UTC
Created attachment 118570 [details]
netbeans launcher's log

Javier, could you run your IDE from command prompt with a switch for catch log of netbeans launcher and attach it here? It could show if a problem is in Autoupdate code or in NB launcher. Run netbeans.exe --trace launcher_output.txt and install a update. For manually restart call netbeans.exe --trace launcher_output_restart.txt then attach attach both logs. Thanks
Comment 14 javydreamercsw 2012-04-20 22:54:19 UTC
Created attachment 118584 [details]
Update log
Comment 15 javydreamercsw 2012-04-20 22:54:39 UTC
Created attachment 118585 [details]
Restart log

Added logs as requested.
Comment 16 Libor Fischmeistr 2012-04-23 14:48:35 UTC
Created attachment 118640 [details]
Launcher DLL - additional logging

Hi, I was running NB on this config:

Product Version         = NetBeans IDE Dev (Build 201204220400) (#837d69a29c6d)
Operating System        = Windows 7 version 6.1 running on x86
Java; VM; Vendor        = 1.7.0; Java HotSpot(TM) Client VM 21.0-b17; Oracle Corporation
Runtime                 = Java(TM) SE Runtime Environment 1.7.0-b147
System Locale; Encoding = en_US (nb); Cp1252

and everything worked well. I tried to reproduce this bug several times on 64bit as well on 32bit system. Alsways with succesfull result.

So I would ask you to use dll you can find in attachement and replace the one in {NB_INSTALLATION_FOLDER}\platform\lib. Then run 32 bit launcher same as in previous case an attach here logs you got. Also please attach here the log file you got when running without any updates.

These logs should be useful for us and I thank you for them in advance.
Comment 17 javydreamercsw 2012-04-23 17:25:08 UTC
Created attachment 118652 [details]
Enhanced Update log
Comment 18 javydreamercsw 2012-04-23 17:25:30 UTC
Created attachment 118653 [details]
Enhanced Restart log

Logs as requested.
Comment 19 Libor Fischmeistr 2012-04-24 12:56:10 UTC
Thank you for your attachments.

Today I have tried to reproduce this problem on almost the same config as you have: Win 7 32bit, Java 7u3, NB 7.1.1 (All zip distribution). All running from flash disk and everything worked fine.

Based on our investigation and consulting on Windows specific forums we realized that Windows runtime might suppress event about detaching NB dll which usually starts the updatechecking process we cannot fix it in our code. We are going to mention the problem in NB release notes. Thank you for your feedback again.
Comment 20 Libor Fischmeistr 2012-06-12 12:17:03 UTC
*** Bug 213976 has been marked as a duplicate of this bug. ***
Comment 21 Libor Fischmeistr 2012-10-01 14:40:31 UTC
*** Bug 219239 has been marked as a duplicate of this bug. ***
Comment 22 Marian Mirilovic 2012-10-01 14:44:09 UTC
We are getting also emails about this problem from community. Libor is there a way to handle it better ?
Comment 23 Jiri Rechtacek 2012-10-01 14:46:45 UTC
We are finding a workaround of missing events from Windows runtime.
Comment 24 Jiri Rechtacek 2012-10-01 14:47:22 UTC
*** Bug 219252 has been marked as a duplicate of this bug. ***
Comment 25 Libor Fischmeistr 2012-10-03 08:04:39 UTC
This behavior is very weird. I retested it several times on two different systems: Windows 7 Professional SP1 and Windows 7 Enterprise (with and without SP1). On both the JDK 7u7 was installed and the same NetBeans 7.2 was used (zip). On  Enterprise version it still works properly, every time it restarts perfectly. On Professional version the NetBeans never restarted (64bit version! 32 works well). There is no difference between used NetBeans but the application behaves differently. Due to it I think it's caused by Windows libraries. So several options appears here. We can report it to MS or we can try to recompile nbexec.dll with some new switches and config (like alchemy).

I tried it on Windows 8 Release Preview and restart also worked...

I want to ask you all to report here what version of Windows do you have, if you have Service Pack and if the NetBeans restarts or not.

Thanks
Comment 26 Jiri Skrivanek 2012-10-03 09:04:57 UTC
NetBeans never restarts.

Windows 7 Professional 64 bit Service Pack 1
Java: 1.7.0_07; Java HotSpot(TM) 64-Bit Server VM 23.3-b01
Comment 27 Libor Fischmeistr 2012-10-03 09:05:52 UTC
(In reply to comment #26)
> NetBeans never restarts.
> 
> Windows 7 Professional 64 bit Service Pack 1
> Java: 1.7.0_07; Java HotSpot(TM) 64-Bit Server VM 23.3-b01

Do you have OBI?
Comment 28 Libor Fischmeistr 2012-10-08 07:56:07 UTC
Tried to reproduce it on Win 7 Enterprise 64bit SP1 (in VirtualBox) 1, 2 and 4 processors but restart worked. Also on Win 7 Professional (not as virtual) 64bit SP1 - worked.
Comment 29 Libor Fischmeistr 2012-10-19 06:31:49 UTC
Fixed in http://hg.netbeans.org/core-main/rev/dea8d4876cbd

Thanks to Ondra Vrabec who found the final solution.

I want to ask you all to verify this solution.
Comment 30 Quality Engineering 2012-10-25 10:54:14 UTC
Integrated into 'main-golden', will be available in build *201210250921* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/dea8d4876cbd
User: Libor Fischmeistr <lfischmeistr@netbeans.org>
Log: #207579: When updating or import plugins Netbeans asks to restart now or later if restart now is chosen it would not restart Automatically i have to click the shortcut to start Netabeans again so that update takes effect
Comment 31 Jiri Skrivanek 2012-10-25 11:04:40 UTC
Great! It works finally.
Comment 32 Marian Mirilovic 2012-10-25 11:52:42 UTC
*** Bug 220747 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo