Bug 207507 - Move .netbeans-derby to OS specific default location
Move .netbeans-derby to OS specific default location
Status: VERIFIED FIXED
Product: db
Classification: Unclassified
Component: Derby
7.2
All All
: P3 (vote)
: TBD
Assigned To: matthias42
issues@db
:
: 154845 (view as bug list)
Depends on: 49813 196075
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-19 11:19 UTC by Jiri Rechtacek
Modified: 2015-12-07 10:29 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Rechtacek 2012-01-19 11:19:37 UTC
See issue 196075
Comment 1 matthias42 2014-01-07 13:03:34 UTC
*** Bug 154845 has been marked as a duplicate of this bug. ***
Comment 2 matthias42 2015-12-04 21:22:13 UTC
The change was pushed as:

http://hg.netbeans.org/core-main/rev/2f36658c7106

I would like to ask especially windows users to give this a try when the patch is integrated into the next nightly.

This should happen:

- If your on a UNIX like system, you should see no difference (the derby default is then $HOME/.netbeans-derby
- If your on windows and start with a fresh configuration:
  - if there is an existing directory %AppData%/Netbeans/Derby it is used
  - if there is an existing .netbeans-derby in the old location this will be used
  - if none of the above exist %AppData%/Netbeans/Derby is used

If you find it fixed, please change the state of this bug to VERIFIED.
Comment 3 Quality Engineering 2015-12-06 02:31:23 UTC
Integrated into 'main-silver', will be available in build *201512060002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/2f36658c7106
User: Matthias Blaesing <matthias42@netbeans.org>
Log: #207507: move derby datadir directory on windows to %AppData%/NetBeans/Derby
Comment 4 terje7601 2015-12-07 10:29:26 UTC
Thank you for fixing this Matthias. I just verified it with the latest dev build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo