Bug 207402 - [71cat] IllegalArgumentException: Parameter file was not normalized. Was /.. instead of /
[71cat] IllegalArgumentException: Parameter file was not normalized. Was /.. ...
Status: RESOLVED FIXED
Product: php
Classification: Unclassified
Component: Editor
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Ondrej Brejla
issues@php
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-17 15:21 UTC by schkovich
Modified: 2012-01-25 16:31 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.66 KB, text/plain)
2012-01-17 15:21 UTC, schkovich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description schkovich 2012-01-17 15:21:16 UTC
This bug was originally marked as duplicate of bug 185643, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201201160947)
VM: Java HotSpot(TM) 64-Bit Server VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Linux

User Comments:
schkovich: tryning to get autocompletition for folder/file names in require_once './../../';




Stacktrace: 
java.lang.IllegalArgumentException: Parameter file was not normalized. Was /.. instead of /
   at org.openide.filesystems.FileUtil.toFileObject(FileUtil.java:1030)
   at org.netbeans.modules.php.editor.FSCompletion.computeRelativeItems(FSCompletion.java:217)
   at org.netbeans.modules.php.editor.FSCompletion.access$000(FSCompletion.java:96)
   at org.netbeans.modules.php.editor.FSCompletion$1$1.run(FSCompletion.java:159)
   at org.netbeans.modules.parsing.impl.TaskProcessor.callUserTask(TaskProcessor.java:643)
   at org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:154)
Comment 1 schkovich 2012-01-17 15:21:18 UTC
Created attachment 114973 [details]
stacktrace
Comment 2 Ondrej Brejla 2012-01-19 14:32:00 UTC
Fixed in web-main: http://hg.netbeans.org/web-main/rev/63cb16ceafcf
Comment 3 Quality Engineering 2012-01-25 16:31:39 UTC
Integrated into 'main-golden', will be available in build *201201250600* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/63cb16ceafcf
User: Ondrej Brejla <obrejla@netbeans.org>
Log: #207402 - [71cat] IllegalArgumentException: Parameter file was not normalized. Was /.. instead of /


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo