Bug 207266 - [71cat] IllegalStateException: Common server instance not found for [C:\Software\glassfish\3.1.1-b12\glassfish;C:\Software\glassfish\3.1.1-b12\glassfish\domains\domain1]deployer:gfv3ee6wc:localhost:4848
[71cat] IllegalStateException: Common server instance not found for [C:\Softw...
Status: NEW
Product: serverplugins
Classification: Unclassified
Component: GlassFish
7.1
All All
: P3 (vote)
: 8.0
Assigned To: TomasKraus
issues@serverplugins
EXCEPTIONS_REPORT NB_ONLY
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-13 10:47 UTC by tim_sa
Modified: 2013-07-18 14:38 UTC (History)
22 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (773 bytes, text/plain)
2012-01-13 10:47 UTC, tim_sa
Details
stacktrace (773 bytes, text/plain)
2012-01-13 13:17 UTC, tim_sa
Details
stacktrace (773 bytes, text/plain)
2012-01-13 15:14 UTC, tim_sa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tim_sa 2012-01-13 10:47:48 UTC
This bug was originally marked as duplicate of bug 198205, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.1 (Build 201112071828)
VM: Java HotSpot(TM) 64-Bit Server VM, 22.0-b10, Java(TM) SE Runtime Environment, 1.7.0_02-b13
OS: Windows 7

User Comments:
GUEST: start a java dynamic web application on glassfish

kurti: I had 2 Glassfish in the configuration and removed the entry under "services" which relates to the instance named in the summary

GUEST: Starting war project by doing RUN.

GUEST: Attempting to run program in debug

mv7402: problem ib the Netbeans build - 200902190601

GUEST: clicked debug to start debug session on java file

ahleong: run debug

aldobrucale: Attach remote jpda debugger

malakim: Launching a debugging session for a web application running on Glassfish V2.1

jag: Starting to debug; this is not an EE app - no server!

GUEST: Trying to start the attach to a Grails debug session using the Debug Attach command. Not sure what it has to do with glassfish ... using an external jetty application server.

annamoto: launching a run as debug

GUEST: Tried to start debugging an ordinary Java Application.

jag: Starting desktop app - no need for glassfish!!

GUEST: Starting debugger

dlmerryweather: Debugging PHP App

jag: Starting to debug a project

bernd_zedv: startet Debug File

GUEST: launching UI project in debug mode

GUEST: Debugging an Java application (no swing or web, just pure java with jdbc and hibernate)

GUEST: CTRL+F5

GUEST: package deckofcards;

import java.util.List;
import java.util.Arrays;
import java.util.Collections;
/**
 *
 * @author csharp
 */
class Card {
	public static enum Face {
		Ace, Duece, Three, Four, Five, Six, Seven, Eight, Nine, Ten, Jack, Queen, King
	};

	public static enum Suit {
		Clubs, Diamonds, Hearts, Spades
	};

	private final Face face;
	private final Suit suit;

	public Card(Face cardFace, Suit cardSuit) {
		face = cardFace;
		suit = cardSuit;
	}

	public Face getFace() {
		return face;
	}

	public Suit getSuit() {
		return suit;
	}

	@Override
	public String toString() {
		return String.format("%s of %s", face, suit);
	}
}

public class DeckOfCards {

  private List<Card> list;
	/**
     * @param args the command line arguments
     */
	public DeckOfCards() {

		Card[] deck = new Card[52];
		int count = 0;

		for(Card.Suit suit : Card.Suit.values()) {
			for(Card.Face face : Card.Face.values()) {
				deck[count] = new Card(face, suit);
				count++;
			}
		}
		list = Arrays.as

GUEST: debug php project

emiddio: trying to debug

pepijn: starting debug session

ender01: I had removed multiple GF instances from the servers section and then started a GF2 up in debug mode. This error came from trying to attach the debugger to this GF2 instance. (it still attached, but generated this error)

bwells2004: Start the app up in debug mode and the exception appeared.

GUEST: Launching a debug session of a web application with javascript in a JSP and a breakpoint in the Java.  Also in the project is an empty Java class.

GUEST: Trying to debug an Application Client.  Was having problems with 6.7 so I downloaded and installed 6.7.1 and now can't get it deployed properly

GUEST: Error occurred when trying to run debugger

dkittle: I was trying to attach the debugger to an application running in WebLogic (configured for remote debugging).

GUEST: I tried running the project and i got this error

GUEST: Starting embedded Tomcat.  Do not have Glassfish installed.

haskovec: launching the debugger to attach to my tomcat process.

annamoto: launching a debug, on a library project, this project has nothing in common with a glassfish-v3-prelude project or anything needs deployment

GUEST: deploying a war to glassfish v3

pepijn: starting a debug session

jonast: Debuggin test files




Stacktrace: 
java.lang.IllegalStateException: Common server instance not found for [C:\Software\glassfish\3.1.1-b12\glassfish;C:\Software\glassfish\3.1.1-b12\glassfish\domains\domain1]deployer:gfv3ee6wc:localhost:4848
   at org.netbeans.modules.glassfish.javaee.Hk2DeploymentManager.getServerInstance(Hk2DeploymentManager.java:606)
   at org.netbeans.modules.glassfish.javaee.Hk2StartServer.getCommonServerSupport(Hk2StartServer.java:114)
   at org.netbeans.modules.glassfish.javaee.Hk2StartServer.isRunning(Hk2StartServer.java:342)
   at org.netbeans.modules.j2ee.deployment.impl.ServerInstance$3.run(ServerInstance.java:908)
   at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1411)
   at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1991)
Comment 1 tim_sa 2012-01-13 10:47:52 UTC
Created attachment 114865 [details]
stacktrace
Comment 2 tim_sa 2012-01-13 13:17:49 UTC
Created attachment 114872 [details]
stacktrace
Comment 3 tim_sa 2012-01-13 15:14:49 UTC
Created attachment 114878 [details]
stacktrace

Hit rdebug

I did remove this GlassFish Server from my netbeans installation earlier. Howevr the project that I am currently debugging does not use an application server
Comment 4 TomasKraus 2012-05-23 09:16:31 UTC
Targeting after Tooling SDK (new library for Glassfish IDE modules) implementation will be finished and integrated into NetBeans.

Assingning to myself.
Comment 5 TomasKraus 2013-03-26 16:36:14 UTC
NetBeans web-main:
------------------
changeset:   248978:d5bc68b85d56
branch:      javaee7
summary:     #207266 - Changed Hk2DeploymentManager.getServerInstance
             to look better

This is just a cosmetic change.

Looks like you were able to cause some inconsistency in GlassishInstanceProvider.
Hk2DeploymentManager.getServerInstance is just a front end to retrieve server instance from GlassishInstanceProvider using internal server URI as a key.

There was no server matching given URI found and it's just complaining about that.
Comment 6 TomasKraus 2013-04-17 15:07:01 UTC
I will have to rewrite URI handling in 7.4 because with GlassFish 4 current URI strings make no sense.
I will probably remove all those gfv3ee6, gfv3ee6wc, gfv3 and others and use common URI prefix for all servers.
Comment 7 TomasKraus 2013-07-18 14:38:43 UTC
Postponing to next release, there is no time for rewriting URI handling in 7.4 cycle.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo