Bug 207075 - Update center omits OSGi bundles
Update center omits OSGi bundles
Status: RESOLVED FIXED
Product: www
Classification: Unclassified
Component: Builds & Repositories
7.1
All All
: P3 with 2 votes (vote)
: 7.2
Assigned To: pgebauer
nbre
:
: 209119 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-09 17:10 UTC by Jesse Glick
Modified: 2014-02-16 11:23 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2012-01-09 17:10:45 UTC
http://updates.netbeans.org/netbeans/updates/7.1/uc/final/distribution/catalog.xml.gz does not list any OSGi bundles. Among other things, this means that an Ant-based NBM suite which uses autoupdate.catalog.url to download required clusters from the NB platform will be missing these bundles (e.g. com-jcraft-jsch.jar).

http://deadlock.netbeans.org/hudson/job/nbms-and-javadoc/lastStableBuild/artifact/nbbuild/nbms/updates.xml.gz does contain them, so there is nothing inherently wrong with the Ant tasks which generate update centers, just with how these were used for the release build.
Comment 1 Jesse Glick 2012-01-10 17:28:32 UTC
Complicates building of NB-Ruby against 7.1, and prevents SQE from doing so at all. Needs to be addressed soon.
Comment 2 pgebauer 2012-01-18 11:39:59 UTC
Could you please check whether the following AUC has fixed the problem?
http://dlc.sun.com.edgesuite.net/netbeans/updates/7.1/uc/final/distribution/catalog_stage.xml
Comment 3 Jesse Glick 2012-01-18 22:06:44 UTC
The AUC now includes the bundles. Unfortunately <autoupdate> still ignores the bundles since they have no targetcluster attribute, due to an apparent bug in <makeupdatedesc>; I am working on a fix, and you will need to regenerate the update center using a patched MakeUpdateDesc.java.

AutoUpdate.java also fails to handle bundles at all, it turns out, which I will also fix, but that requires no attention from you as the UC creator. Anyone using bootstrap.url=http://deadlock.netbeans.org/hudson/job/nbms-and-javadoc/lastStableBuild/artifact/nbbuild/netbeans/harness/tasks.jar will pick up that fix in due time.
Comment 4 Jesse Glick 2012-01-18 23:42:39 UTC
(In reply to comment #3)
> you will need to regenerate the
> update center using a patched MakeUpdateDesc.java.

http://hg.netbeans.org/core-main/raw-diff/9b8af74181d9/nbbuild/antsrc/org/netbeans/nbbuild/MakeUpdateDesc.java
Comment 5 pgebauer 2012-01-23 13:51:12 UTC
I have refreshed the file
http://dlc.sun.com.edgesuite.net/netbeans/updates/7.1/uc/final/distribution/catalog_stage.xml

Could you please check it?
Comment 6 Jesse Glick 2012-01-23 22:41:42 UTC
Looks good so far as I can tell - please make it live.
Comment 8 Jesse Glick 2012-01-24 17:12:18 UTC
catalog.xml not only does not include OSGi bundles, but catalog_stage.xml now does not either.
Comment 9 Jesse Glick 2012-01-25 15:02:34 UTC
Seems to have been a DLC caching problem; fixed catalog.xml now live and confirmed in both SQE and community-ruby.
Comment 10 Quality Engineering 2012-01-25 16:36:05 UTC
Integrated into 'main-golden', will be available in build *201201250600* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/9b8af74181d9
User: Jesse Glick <jglick@netbeans.org>
Log: #207075: more OSGi handling fixes.
Set targetcluster in updates.xml according to directory containing bundle.
If a bundle is downloaded, create config/Modules/*.xml for it and otherwise copy the JAR.
Comment 11 Jesse Glick 2012-03-03 00:17:58 UTC
*** Bug 209119 has been marked as a duplicate of this bug. ***
Comment 12 Jesse Glick 2012-03-03 00:18:25 UTC
Duplicate issue indicates that an UC on bits.netbeans.org is still broken.
Comment 13 pgebauer 2012-06-12 13:02:40 UTC
I can see the correct catalog.xml at http://dlc.sun.com.edgesuite.net/netbeans/updates/7.1/uc/final/distribution
Comment 14 Jesse Glick 2012-06-12 16:47:21 UTC
http://bits.netbeans.org/netbeans/7.1/fcs/uc/catalog.xml.gz still appears broken as mentioned in bug #209119.
Comment 15 pgebauer 2012-06-13 12:09:04 UTC
I have updated both catalog.xml and catalog.xml.gz at http://bits.netbeans.org/netbeans/7.1/fcs/uc/ . 

However I would like to remark that the only valid and up to date catalogs reside at http://dlc.sun.com.edgesuite.net/netbeans/updates/7.1/uc/final/distribution/ .
Comment 16 Jesse Glick 2012-06-13 17:25:47 UTC
(In reply to comment #15)
> the only valid and up to date catalogs reside at dlc.sun.com.edgesuite.net

Fine enough, since that is what harness/README suggests (via the redirect from updates.netbeans.org). But since at least someone has come across the bits.netbeans.org UCs (as in bug #209119), these need to be either kept up to date as well, or deleted so that there is no chance of confusion.
Comment 17 Jackie_Rosen 2014-02-16 11:23:26 UTC
SPAM - Removed by Administrator


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo