Bug 206912 - netbeans rc2 fails to connect to internet
netbeans rc2 fails to connect to internet
Status: CLOSED INCOMPLETE
Product: platform
Classification: Unclassified
Component: Autoupdate
7.1
PC Windows 7 x64
: P2 (vote)
: 7.2
Assigned To: Jiri Rechtacek
au-issues
jdk_bug_7127232-not-reproducible
:
Depends on:
Blocks: 200826
  Show dependency treegraph
 
Reported: 2012-01-04 16:03 UTC by aplatypus
Modified: 2012-07-17 15:06 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
user log folder, netbeans trace file, and netbeans console output (22.77 KB, application/x-zip-compressed)
2012-01-04 16:03 UTC, aplatypus
Details
user log folder, netbeans trace file, and netbeans console output (38.84 KB, application/x-zip-compressed)
2012-01-04 16:12 UTC, aplatypus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aplatypus 2012-01-04 16:03:59 UTC
Created attachment 114630 [details]
user log folder, netbeans trace file, and netbeans console output

Start-up netbeans 7.1 rc2

Menu:

  help / Check for updates

Dialog times-out and doesn't connect to the internet.

NO proxy or other impediment is active.

**  I wanted to ask if there is a simple command line tool I can use to verify that netbeans access to sockets or the internet is functional or not functional?

I have included a ZIP of the netbeans user log folder:

   c:\Users\william\.netbeans\7.1rc2\var

Which includes a capture of the console output and netbeans --Trace file.

Please note the following error from the "get updates" menu command:

  Java DLL path: b:\lang\java\jdk\x64\v1.7\u01\jre\bin\server\jvm.dll
  PrepareDllPath: b:\lang\java\jdk\x64\v1.7\u01\jre\bin
  Cannot load b:\lang\java\jdk\x64\v1.7\u01\jre\bin\server\jvm.dll. %1 is not a valid Win32 application. (193)
  Falling back to running Java in a separate process; DLL cannot be loaded (64-bit DLL?).


It appears to me that something is NOT loading, and can't connect to the internet due to a x32-bit / x64-bit problem with either netbeans or java sdk.

At the very least there's a problem with the error message showing "%1" instead of the name of the thing that can't load.

good luck,

w.
Comment 1 aplatypus 2012-01-04 16:12:35 UTC
Created attachment 114631 [details]
user log folder, netbeans trace file, and netbeans console output

netbeans log and output captures
Comment 2 Jiri Rechtacek 2012-01-05 13:37:38 UTC
Could you try it again today night or later? NB7.1 is coming out right and perhaps something wrong on a server side. The UC seems to be working now. Thanks.
If a problem persists I send you a switch for more verbose logging.
Comment 3 aplatypus 2012-01-08 12:28:27 UTC
Some progress, though not from the place you'd expect.

I did a little experiment with other Java programs that access the net.  Eclipse, Netbeans and Lobo (the Java browser).  They all work with Java v1.6 u29 (64-bit windows).

They all Fail with Java 1.7 u01 (64-bit windows).

Command line example.

Java 6 -- Works ::

    b:\lang\java\jre\x64\v1.6\u29\bin\java.exe -jar c:\.bin\media\lobo\v00.98\lobo.jar

Java 7 -- Failed ::

    b:\lang\java\jre\x64\v1.7\u01\bin\java.exe -jar c:\.bin\media\lobo\v00.98\lobo.jar


And Netbeans:

  %NETBEANS_HOME%\bin\netbeans.exe --jdkhome %JDK_HOME%

Using the matching Java v1.6 u29 (64-bit) JDK.

The culprit seems to be Java 1.7 itself or the install file.

I've submitted a bug against Java using the Lobo example.  Oracle bug ID:

  #7127232
  http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=7127232

If anyone has helpful suggestions, please update the bug entry.

Advice for someone having trouble with the new netbeans and Java 1.7, roll back to 1.6 u29 (or better).

w.
Comment 4 Jiri Rechtacek 2012-01-12 15:09:45 UTC
I'm able to reproduce this on Win Vista 32-bit. Works for me with JDK6, doesn't work with Java 7u2-b13.
Comment 5 Jiri Rechtacek 2012-01-12 15:38:12 UTC
(In reply to comment #4)
> I'm able to reproduce this on Win Vista 32-bit. Works for me with JDK6, doesn't
> work with Java 7u2-b13.

A correction: it's reproducible with Lobo Browser, not reproducible with jvisualvm. Seems a problem could be on Lobo Browser side.
Comment 6 aplatypus 2012-01-13 10:13:03 UTC
It is good the 32-bit version works with jvisualvm.

I tested jvisualvm with the JDK 1.7, 64-bit before trialling lobo.  My choice of lobo was to isolate the issue from netbeans (jvisualvm is a netbean platform app).
Comment 7 Marian Mirilovic 2012-07-17 15:06:29 UTC
JDK team closed this bug as "Not Reproducible"


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo