Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 206863 - IndexOutOfBoundsException: Invalid index=8; foldCount=4 component=16135710 [root-fold] E <0,11167>, hash=0x1cea0c1, [0, 11167] {0, 11167} [0]: [tag] E0 <371,428>, desc='<.../>', hash=0x1667373, [3
IndexOutOfBoundsException: Invalid index=8; foldCount=4 component=16135710 [r...
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: JSP
7.2
All All
: P2 (vote)
: 7.3
Assigned To: Marek Fukala
issues@javaee
EXCEPTIONS_REPORT, 72ca-not-a-stopper
:
: 208823 210090 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-03 09:58 UTC by sgtgarcia
Modified: 2013-01-17 12:31 UTC (History)
16 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.25 KB, text/plain)
2012-01-03 09:58 UTC, sgtgarcia
Details
stacktrace (3.24 KB, text/plain)
2012-10-24 12:57 UTC, ecerichter
Details
stacktrace (3.24 KB, text/plain)
2012-11-18 19:52 UTC, ecerichter
Details
stacktrace (3.24 KB, text/plain)
2012-12-18 02:56 UTC, ecerichter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sgtgarcia 2012-01-03 09:58:14 UTC
This bug was originally marked as duplicate of bug 189576, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201112190600)
VM: Java HotSpot(TM) Client VM, 20.1-b02, Java(TM) SE Runtime Environment, 1.6.0_26-b03
OS: Windows 7

User Comments:
zoren: Editing JSTL expression

sgtgarcia: Editing JSP

GUEST: Occurred when I tried edit a JSTL code.

zoren: Editing HTML in JSP file

This exception occured when I commented that code:

<%--
    <tr>
        <td colspan="2">
            <input type="submit" name="enviar" value="Consultar" />
        </td>
    </tr>
--%>

GUEST: Only editing a jsp with JSTL.

GUEST: Commenting out some code I received a (NetBeans) fatal error on

GUEST: editing a jsp page with displaytag

GUEST: I created a table with columns like: Book's name, Book's author, Book's isbn
then I tried opening <% tag, and got this message

GUEST: ?? jsp??

GUEST: commenting out a block in JSP file.




Stacktrace: 
java.lang.IndexOutOfBoundsException: Invalid index=8; foldCount=4
component=16135710
[root-fold] E <0,11167>, hash=0x1cea0c1, [0, 11167] {0, 11167}
    [0]: [tag] E0 <371,428>, desc='<.../>', hash=0x1667373, [371, 428] {372, 427}
    [1]: [tag] E0 <430,11166>, desc='<.../>', hash=0x125a596, [430, 11166] {431, 11165}
        [0]: [tag] E0 <512,946>, desc='<.../>', hash=0x18bae8e, [512, 946] {513, 945}
        [1]: [tag] E0 <1174,8942>, desc='<.../>', hash=0x1ce251a, [1174, 8942] {1175, 8941}
            [0]: [tag] E0 <1299,8908>, desc='<.../>', hash=0xe5eda9, [1299, 8908] {1300, 8907}
                [0]: [tag] E0 <1481,3666>, desc='<.../>', hash=0x1560739, [1481, 3666] {1482, 3665}
                    [0]: [tag] E0 <1664,1858>, desc='<.../>', hash=0xf4370c, [1664, 1858] {1665, 1857}
                    [1]: [tag] E0 <1963,2149>, desc='<.../>', hash=0x14a2274, [1963, 2149] {1964, 2148}
                    [2]: [tag] E0 <2305,2793>, desc='<.../>', hash=0x1bf26f, [2305, 2793] {2306, 2792}
                    [3]
   at org.netbeans.modules.editor.fold.FoldChildren.getFold(FoldChildren.java:118)
   at org.netbeans.api.editor.fold.Fold.getFold(Fold.java:324)
   at org.netbeans.api.editor.fold.Fold.replaceByChildren(Fold.java:375)
   at org.netbeans.api.editor.fold.FoldHierarchy$ApiPackageAccessorImpl.foldReplaceByChildren(FoldHierarchy.java:382)
   at org.netbeans.modules.editor.fold.FoldHierarchyTransactionImpl.removeFoldFromHierarchy(FoldHierarchyTransactionImpl.java:944)
   at org.netbeans.modules.editor.fold.FoldHierarchyTransactionImpl.removeOverlap(FoldHierarchyTransactionImpl.java:925)
Comment 1 sgtgarcia 2012-01-03 09:58:17 UTC
Created attachment 114573 [details]
stacktrace
Comment 2 medeag 2012-02-24 15:07:50 UTC
*** Bug 208823 has been marked as a duplicate of this bug. ***
Comment 3 Svata Dedic 2012-03-15 14:41:21 UTC
All reports are related to JSP, so this defect should probably target JspFoldManager. Anyway, during December 2011, I've made some fixes since the FoldManagers were not released properly and events were not suspended when the component was replaced or re-parented in a multitab container.

There's quite a chance that this defect is fixed *in dev version*. The fix was *not* integrated in 7.1x branches, so all 7.1 reports could be obsoleted by those changes.
Comment 4 Svata Dedic 2012-03-27 06:37:44 UTC
*** Bug 210090 has been marked as a duplicate of this bug. ***
Comment 5 Vladimir Riha 2012-07-12 10:37:44 UTC
I can't reproduce it. Can you please evaluate? There are few reports from 7.2 dev as well. Thanks
Comment 6 ecerichter 2012-10-24 12:57:16 UTC
Created attachment 126471 [details]
stacktrace

Introducing a new <%@taglib into the JSP page. When I was about to select my custom taglib, error was thrown.
Comment 7 ecerichter 2012-11-18 19:52:32 UTC
Created attachment 128014 [details]
stacktrace

Editando p?gina HTML (s? adicionei um "<br>" ao c?digo existente).
Comment 8 ecerichter 2012-12-18 02:56:15 UTC
Created attachment 129487 [details]
stacktrace

Opening editor.
Comment 9 Marian Mirilovic 2013-01-03 14:10:05 UTC
106 dups ... tens from 7.3 Beta / Beta 2 -> P2
Comment 10 Marek Fukala 2013-01-08 13:28:50 UTC
fixed in web-main#5d331e382ab8
Comment 11 Quality Engineering 2013-01-09 02:25:02 UTC
Integrated into 'main-golden', will be available in build *201301090001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/5d331e382ab8
User: Marek Fukala <mfukala@netbeans.org>
Log: #206863 - jsf code folding issues


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo