Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 206837 - [error checks] Layers in css background-image property results in Unexpected value token warning
[error checks] Layers in css background-image property results in Unexpected ...
Status: RESOLVED DUPLICATE of bug 206035
Product: web
Classification: Unclassified
Component: CSS Visual Tools
7.2
PC Linux
: P3 with 1 vote (vote)
: 7.2
Assigned To: Marek Fukala
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-02 10:26 UTC by Vladimir Riha
Modified: 2012-04-27 09:32 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2012-01-02 10:26:05 UTC
In CSS3, there could be layered background images (see http://www.w3.org/TR/2011/CR-css3-background-20110215/#layering)

But when you try this in css file:

div{
background-position: center center, 20% 80%, top left, bottom right;
}

it is marked with warning 'Unexpected value token,'. The same goes for 

div{
border-image: url(../img/examp/li/borderimage1.png) 9 round;
}


Product Version: NetBeans IDE Dev (Build 201201010601)
Java: 1.7.0_02; Java HotSpot(TM) Client VM 22.0-b10
System: Linux version 3.0.0-14-generic-pae running on i386; UTF-8; en_US (nb
Comment 1 micnolmad 2012-04-14 17:02:32 UTC
It is the same for the shorthand background:url(image);
Comment 2 Marek Fukala 2012-04-16 11:15:25 UTC
valid, needs to be fixed
Comment 3 Marek Fukala 2012-04-27 09:32:10 UTC
I believe the cause is the same what I filed as issue 206035

*** This bug has been marked as a duplicate of bug 206035 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo