Bug 206567 - LowPerformance took 4007 ms
LowPerformance took 4007 ms
Status: RESOLVED FIXED
Product: php
Classification: Unclassified
Component: Project
7.1
All All
: P3 (vote)
: 7.4
Assigned To: Tomas Mysik
issues@php
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 228233 232281 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-20 11:33 UTC by Marian Petras
Modified: 2013-07-08 06:10 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (10.83 KB, application/nps)
2011-12-20 11:33 UTC, Marian Petras
Details
nps snapshot (808.47 KB, application/nps)
2013-03-09 14:06 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Petras 2011-12-20 11:33:56 UTC
This bug was originally marked as duplicate of bug 177275, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.1 RC2 (Build 201112012200)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.5-b03, Java(TM) SE Runtime Environment, 1.6.0_30-b12
OS: Windows 7

User Comments:
mpetras: I was about to select menu item "Help > About" with a mouse.

When the mouse cursor was over item "Javadoc Index Search", the IDE stopped responding for 4 seconds. Perhaps it was a full GC cycle?



Maximum slowness yet reported was 4007 ms, average is 4007
Comment 1 Marian Petras 2011-12-20 11:33:59 UTC
Created attachment 114348 [details]
nps snapshot
Comment 2 Jan Becicka 2012-02-16 11:38:49 UTC
caused by #41443
Comment 3 Exceptions Reporter 2013-03-09 14:06:32 UTC
Created attachment 132401 [details]
nps snapshot

Adding grails installation
Comment 4 Ralph Ruijs 2013-05-09 14:24:54 UTC
PHP project is validating proxy in EDT.
Comment 5 Tomas Mysik 2013-05-20 14:00:13 UTC
Should be fixed I hope.

http://hg.netbeans.org/web-main/rev/a8323f270f48
Comment 6 Quality Engineering 2013-05-21 02:35:19 UTC
Integrated into 'main-golden', will be available in build *201305202300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/a8323f270f48
User: Tomas Mysik <tmysik@netbeans.org>
Log: #206567 - LowPerformance took 4007 ms
Comment 7 Tomas Mysik 2013-05-21 09:59:46 UTC
*** Bug 228233 has been marked as a duplicate of this bug. ***
Comment 8 WebCF 2013-06-24 12:27:53 UTC
The fix @ http://hg.netbeans.org/main-golden/rev/a8323f270f48 seems to not be included in the NB 7.3.1 release, right? I'm still having the same problem under 7.3.1.

Can someone confirm that?

My proxy settings when it occurs:

* Manual Prox< Settings:
    * HTTP-Proxy: *ip-address*
    * More -> "Use the same proxy settings for all protocols" checked
    * Default "No Proxy Hosts"-list
    * "Proxy Requires Authentication" UNchecked
Comment 9 WebCF 2013-06-24 12:30:06 UTC
(In reply to comment #8)
> The fix @ http://hg.netbeans.org/main-golden/rev/a8323f270f48 seems to not be
> included in the NB 7.3.1 release, right? I'm still having the same problem
> under 7.3.1.
> 
> Can someone confirm that?
> 
> My proxy settings when it occurs:
> 
> * Manual Prox< Settings:
>     * HTTP-Proxy: *ip-address*
>     * More -> "Use the same proxy settings for all protocols" checked
>     * Default "No Proxy Hosts"-list
>     * "Proxy Requires Authentication" UNchecked

(Coming from bug 228233)
Comment 10 Tomas Mysik 2013-06-24 12:33:45 UTC
Yes, see the Target Milestone field (for backported issues, TM is set to 7.3.1).

Thanks.
Comment 11 Tomas Mysik 2013-07-08 06:10:12 UTC
*** Bug 232281 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo