Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 206467 - AssertionError at org.netbeans.modules.parsing.impl.indexing.PathRegistry.createResources
AssertionError at org.netbeans.modules.parsing.impl.indexing.PathRegistry.cre...
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
7.2
All All
: P2 (vote)
: 7.2
Assigned To: Tomas Zezula
issues@editor
EXCEPTIONS_REPORT
:
: 206534 206535 206541 206548 206576 206612 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-16 09:52 UTC by Tomas Mysik
Modified: 2012-01-02 14:42 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.11 KB, text/plain)
2011-12-16 09:52 UTC, Tomas Mysik
Details
stacktrace (4.53 KB, text/plain)
2011-12-19 14:15 UTC, edjon2000
Details
stacktrace (4.53 KB, text/plain)
2011-12-19 14:18 UTC, edjon2000
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2011-12-16 09:52:21 UTC
Build: NetBeans IDE Dev (Build 20111216-4ea8cc2bb650)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.5-b03, Java(TM) SE Runtime Environment, 1.6.0_30-b12
OS: Linux

User Comments:
tmysik: ide just started




Stacktrace: 
java.lang.AssertionError
   at org.netbeans.modules.parsing.impl.indexing.PathRegistry.createResources(PathRegistry.java:619)
   at org.netbeans.modules.parsing.impl.indexing.PathRegistry.getSources(PathRegistry.java:253)
   at org.netbeans.modules.parsing.impl.indexing.errors.Utilities.findIndexedRootsUnderDirectory(Utilities.java:85)
   at org.netbeans.modules.parsing.impl.indexing.errors.ErrorAnnotator$1.run(ErrorAnnotator.java:321)
   at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1411)
   at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1991)
Comment 1 Tomas Mysik 2011-12-16 09:52:23 UTC
Created attachment 114257 [details]
stacktrace
Comment 2 Tomas Mysik 2011-12-16 10:08:07 UTC
Happens all the time (even with a clean userdir).
Comment 3 Tomas Zezula 2011-12-16 10:56:57 UTC
Someones registers URL with host into GPR.
This slows down the IDE significantly.
Comment 4 Tomas Mysik 2011-12-16 11:58:47 UTC
(In reply to comment #3)
> Someones registers URL with host into GPR.
> This slows down the IDE significantly.

java.lang.AssertionError: nbfs://nbhost/SystemFileSystem/PHP/RuntimeLibraries/
Comment 5 Tomas Zezula 2011-12-16 15:00:46 UTC
In that case you are the root of the problem ;-)
Comment 6 Tomas Mysik 2011-12-16 15:30:26 UTC
(In reply to comment #5)
> In that case you are the root of the problem ;-)

Feel free to reassign (php/Editor I guess) but please provide why we shouldn't do so and how to fix it.

Thanks.
Comment 7 Tomas Mysik 2011-12-16 15:31:14 UTC
And it is P2 since the PHP editor is almost unusable (AssertionError appears very often).
Comment 8 Ondrej Brejla 2011-12-16 16:56:26 UTC
I looked at that a bit and it seems that it happens in php.project in ClassPathProviderImpl.java:265 where ClassPathSupport.createClassPath() creates that nbfs://nbhost/Sys... form.
Comment 9 Tomas Zezula 2011-12-19 12:54:09 UTC
*** Bug 206535 has been marked as a duplicate of this bug. ***
Comment 10 Tomas Zezula 2011-12-19 12:54:54 UTC
*** Bug 206534 has been marked as a duplicate of this bug. ***
Comment 11 Exceptions Reporter 2011-12-19 14:09:52 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=183849
Comment 12 edjon2000 2011-12-19 14:15:50 UTC
Created attachment 114303 [details]
stacktrace

Commiting altered files
Comment 13 edjon2000 2011-12-19 14:18:50 UTC
Created attachment 114304 [details]
stacktrace

Saving PHP file
Comment 14 Tomas Zezula 2011-12-19 14:27:22 UTC
Fixed jet-main 123d2f864c0e
Comment 15 Tomas Zezula 2011-12-19 14:27:46 UTC
*** Bug 206541 has been marked as a duplicate of this bug. ***
Comment 16 Ondrej Brejla 2011-12-20 09:00:51 UTC
*** Bug 206548 has been marked as a duplicate of this bug. ***
Comment 17 Tomas Zezula 2011-12-20 15:05:42 UTC
*** Bug 206576 has been marked as a duplicate of this bug. ***
Comment 18 Quality Engineering 2011-12-20 15:56:35 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/123d2f864c0e
User: Tomas Zezula <tzezula@netbeans.org>
Log: #206467:AssertionError at org.netbeans.modules.parsing.impl.indexing.PathRegistry.createResources
Comment 19 Tomas Zezula 2011-12-21 09:30:52 UTC
*** Bug 206612 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo