Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 20642 - Using property sheet dropdown menus and dialog buttons require too many clicks
Using property sheet dropdown menus and dialog buttons require too many clicks
Status: VERIFIED DUPLICATE of bug 16542
Product: platform
Classification: Unclassified
Component: Explorer
3.x
All All
: P2 (vote)
: 3.x
Assigned To: Jiri Rechtacek
issues@platform
: UI
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-18 16:26 UTC by kokaku
Modified: 2008-12-22 21:56 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kokaku 2002-02-18 16:26:41 UTC
Currently, to change a property sheet dropdown item, you must click 3 times (once to activate, 
once to popup, once to choose). This behavior is unusual in that no other app (at least on Windows) 
behaves this way.

Ideally, changing the item would take 2 clicks (no click to 
activate).

This also applies to buttons that open dialogs (e.g. Editor > Abbreviations, 
Editor > Key Bindings). A single click should open the dialog.
Comment 1 Jan Chalupa 2002-05-08 15:47:29 UTC
True. There is also a proposal to replace True/False combo-
boxes in property sheets with check-boxes. Only one click 
should be needed to toggle a boolean property (instead of 
the current three clicks).
Comment 2 _ ttran 2002-06-13 22:20:35 UTC
Yes, bad usability.  But not a bug per se.  Changed to RFE and
increased prio.  Will try to do something about it in a future release.
Comment 3 Jiri Rechtacek 2002-07-23 15:38:36 UTC

*** This issue has been marked as a duplicate of 16542 ***
Comment 4 Marian Mirilovic 2003-07-21 16:30:13 UTC
verified - it's duplicate.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo