Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 206377 - Compatibilty with Eclipse Formatter
Compatibilty with Eclipse Formatter
Status: RESOLVED DUPLICATE of bug 197876
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
7.1
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-14 13:47 UTC by tomzi
Modified: 2013-01-12 13:56 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tomzi 2011-12-14 13:47:26 UTC
Please add possibilty to have

.) Spaces after LEFT Braces and before RIGHT Braces:
eg 
  int[] array1 = new int[] { 1, 2, 3 };

.) Insert new Lines for 
  -) Empty class body
     public class Empty {}
  -) empty anonymous class body 
     Listener fListener = new Listener() {};
  -) empty method body
  -) empty enum declaration
      enum EmptyEnum {
      }
  -) empty enum constant body
      enum MyEnum {
         UNDEFINED(0) {
         }
      }
   -) empty annotation body
       @interface EmptyAnnotation {}
   -) at end of line
.) Indent Annotation arguments
    @MyAnnotation(value1 = "this is an example",
            value2 = "of an annotation",
            value3 = "with several arguments",
            value4 = "which may need to be wrapped")
.) Formatting Comments
   -) /* and */ on seperate lines
   -) /** and */ on seperate lines

Product Version = NetBeans IDE 7.1 RC1 (Build 201112051121)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.7.0
Runtime = Java HotSpot(TM) 64-Bit Server VM 21.0-b17
Comment 1 markiewb 2013-01-12 13:56:26 UTC
IMHO a duplicate of http://netbeans.org/bugzilla/show_bug.cgi?id=197876

*** This bug has been marked as a duplicate of bug 197876 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo