Bug 206358 - NPE on D&D or copy-paste in full remote project
NPE on D&D or copy-paste in full remote project
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Remote
7.0
All All
: P2 (vote)
: 7.1.1
Assigned To: Alexander Simon
issues@cnd
701patch-verified, 71patch1-verified
:
: 206368 (view as bug list)
Depends on: 206356 206357
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-14 09:15 UTC by Vladimir Kvashin
Modified: 2012-06-09 12:45 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Stack (1.98 KB, text/plain)
2011-12-14 09:15 UTC, Vladimir Kvashin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Kvashin 2011-12-14 09:15:26 UTC
Created attachment 114133 [details]
Stack

Each time I try copy-pasting files in full remote project (in project view - files view works ok), exception occurs:

java.lang.NullPointerException
	at org.netbeans.modules.cnd.makeproject.ui.ViewItemPasteType.paste(ViewItemPasteType.java:181)
	at org.openide.explorer.view.DragDropUtilities.performPaste(DragDropUtilities.java:202)
Comment 1 Vladimir Kvashin 2011-12-14 09:18:33 UTC
This means that copy-paste does not work at all in full remote. I believe it should be nominated to 7.0.1 patch.
Comment 2 Alexander Simon 2011-12-14 14:27:01 UTC
fixed, change set:
http://hg.netbeans.org/cnd-main/rev/432a5bbb2741

QA please add tests for copy/move.
Expected tests:
- copy item from managed project to managed project on master FS
- copy item from managed project on remote FS to managed project on master FS
- copy item from managed project on master FS to managed project on remote FS
- copy item from managed project on remote FS to managed project on another remote FS
- copy item from unmanaged project to managed project on master FS
- copy item from unmanaged project on remote FS to managed project on master FS
- copy item from unmanaged project on master FS to managed project on remote FS
- copy item from unmanaged project on remote FS to managed project on another remore FS
- copy item from managed project to unmanaged project on master FS
- copy item from managed project on remote FS to unmanaged project on master FS
- copy item from managed project on master FS to unmanaged project on remote FS
- copy item from managed project on remote FS to unmanaged project on another remote FS
- copy item from unmanaged project to unmanaged project on master FS
- copy item from unmanaged project on remote FS to unmanaged project on master FS
- copy item from unmanaged project on master FS to unmanaged project on remote FS
- copy item from unmanaged project on remote FS to unmanaged project on another remote FS
- copy folder from unmanaged project to unmanaged project on master FS
- copy folder from unmanaged project on remote FS to unmanaged project on master FS
- copy folder from unmanaged project on master FS to unmanaged project on remote FS
- copy folder from unmanaged project on remote FS to unmanaged project on another remote FS
- same tests for move
Comment 3 Alexander Simon 2011-12-14 14:37:39 UTC
*** Bug 206368 has been marked as a duplicate of this bug. ***
Comment 4 Quality Engineering 2011-12-15 12:45:15 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/432a5bbb2741
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #206358 NPE on D&D or copy-paste in full remote project
Comment 5 Alexander Pepin 2012-01-12 16:44:42 UTC
Fix failed in build from blacktie. Please check that the fix was ported to blacktie.
java.lang.NullPointerException
    at
org.netbeans.modules.cnd.makeproject.ui.ViewItemPasteType.paste(ViewItemPasteType.java:214)
    at
org.openide.explorer.view.DragDropUtilities.performPaste(DragDropUtilities.java:202)
Comment 6 Vladimir Kvashin 2012-01-13 11:48:16 UTC
transplanted to blackite: rev/0839e938fc00
Comment 7 Alexander Pepin 2012-01-13 17:10:55 UTC
Verified in build from blacktie.
Comment 8 Vladimir Kvashin 2012-02-08 19:38:08 UTC
Already in releases71_fixes.
Comment 9 Alexander Pepin 2012-02-27 14:44:40 UTC
verified in 7.1.1 rc1 build (20120214)
Comment 10 Alexander Pepin 2012-06-09 12:45:51 UTC
Verified in OSS IDE built on NB 7.0.1 patch3


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo