Bug 206320 - Report OOME after restart
Report OOME after restart
Status: RESOLVED DUPLICATE of bug 203598
Product: ide
Classification: Unclassified
Component: Report Exception
7.1
PC All
: P2 (vote)
: 7.2
Assigned To: Tomas Danek
logger-issues@ide
: PLAN
Depends on: 167163
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-13 10:01 UTC by Petr Cyhelsky
Modified: 2013-07-11 15:58 UTC (History)
0 users

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Cyhelsky 2011-12-13 10:01:20 UTC
Current behavior is:
When OOME occurs heap dump is taken and sent to the server. If there is an old heap dump, it is renamed.

The desired behavior is:
When OOME occurs heap dump is taken, but user is only informed about it and about the possibility to send it after the restart of the ide (meybe the user should also be informed that after OOME IDE is in unstable state and it should be restarted ASAP). All the data needed for exception report will be stored. On the next startup it will be detected and standard exception report will be sent.
Comment 1 Tomas Danek 2011-12-13 10:10:50 UTC
sounds very reasonable. Hopefully for 7.2...
Comment 2 Marian Mirilovic 2013-07-11 09:28:12 UTC
I would rather cover this as well by off-line mode of ER (means try to report, if fails add into the queue for the next try to report .... )
Comment 3 Marian Mirilovic 2013-07-11 15:58:10 UTC

*** This bug has been marked as a duplicate of bug 203598 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo