Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 206208 - Build button should be greyed out during builds
Build button should be greyed out during builds
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Generic Projects UI
7.1
All All
: P4 (vote)
: 7.2
Assigned To: Jesse Glick
issues@projects
: UI
Depends on: 71515 212857
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-09 23:00 UTC by Geertjan Wielenga
Modified: 2012-05-31 21:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Geertjan Wielenga 2011-12-09 23:00:17 UTC
The Build button is not greyed-out while a build is in process, making it easy to accidentally trigger multiple simultaneous builds.
Comment 1 Jesse Glick 2011-12-10 13:06:02 UTC
The IDE could (with an API change) detect that a given project command is currently running on a given project, and disable that command on that project for the duration. Extending the disablement to other commands for the same project is questionable - Generate Javadoc might be taking a long time and you want to Run in the meantime. Disabling the command action would not prevent the same or similar Ant targets (or Maven goals) from being invoked via other channels, such as an Ant script's context menu. Nor would you generally want to disable the command for other projects, even though some of them might be in a master-child relationship with this project and so building those might imply also building this. In short, the IDE can only suppress a certain common case of repeated build invocations.

So do not do that then. Usually it is harmless anyway. (And on occasion it is useful to invoke Run multiple times in parallel.)
Comment 2 Jesse Glick 2012-03-20 14:47:52 UTC
core-main #d09adc1b8239
Comment 3 Quality Engineering 2012-03-24 11:00:42 UTC
Integrated into 'main-golden', will be available in build *201203240400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/d09adc1b8239
User: Jesse Glick <jglick@netbeans.org>
Log: #206208: Build button should be greyed out during builds.
Comment 4 Quality Engineering 2012-03-25 09:45:23 UTC
Integrated into 'main-golden', will be available in build *201203250401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/d09adc1b8239
User: Jesse Glick <jglick@netbeans.org>
Log: #206208: Build button should be greyed out during builds.
Comment 5 Jesse Glick 2012-05-29 21:15:35 UTC
*** Bug 213034 has been marked as a duplicate of this bug. ***
Comment 6 Jesse Glick 2012-05-31 21:41:05 UTC
*** Bug 213034 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo