Bug 206182 - External changes not detected on Samba in an open editor
External changes not detected on Samba in an open editor
Status: RESOLVED DUPLICATE of bug 207060
Product: platform
Classification: Unclassified
Component: Filesystems
7.0.1
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Jaroslav Tulach
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-09 09:19 UTC by marcusson
Modified: 2012-01-20 15:53 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description marcusson 2011-12-09 09:19:23 UTC
When using Netbeans on Windows to work on files at a (Linux) Samba share, NB does only occasionally detect external changes.

Expected behavior:

The expected behavior is, that at least the currently open files are checked for changes when the IDE gains back focus.

Actual behavior:

Currently this does not happen. When regaining focus, the IDE sometimes detects the changes, but in most cases it doesn't (feels almost like a caching issue). Even "scan for external changes" doesn't do the trick.

Our test-setup:
- Samba-share on Linux (NFS)
- working on Windows desktop
- open file in current project in IDE
- open same file in other editor (Notepad or any other) and modify it
- give focus back to NB IDE

Expected: NB always detects the open file has changed.
Current: NB does only occasionally detect changes.

Problem:

Other editors work well with Samba, the issue is easy to fix and the problem is a SHOWSTOPPER at least for all people in my office. Many people working in web-development use a setup with Samba-shares on Linux (test systems) via Windows destkop machines (dev environment) so the problem exists in many companies I have seen.

(The problems with NFS in NB have already been discussed in issue 200532. I was asked to open a new bug for the suggested fix.)

Suggested fix:

Other editors simply check the "last modified" date and/or "file size" of
a) either the files that are currently open in the IDE, OR
b) at least the 1 file that currently has the focus in the editor.

There is no need to check the whole project though (other editors don't do it either),
but for the files that are currently open, the effect is quite noticeable (and
annoying).

In case NB already does scan the file's modification date and size, please check whether or not the results are cached.
These results must NOT be cached. (Checks for file-stats should always bypass the cache, since caching beats the whole purpose of checking a "file modification date".)
Comment 1 Jaroslav Tulach 2012-01-20 15:53:00 UTC
Looks like this will be fixed as soon as bug 207060 is fixed.

*** This bug has been marked as a duplicate of bug 207060 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo