Bug 206122 - IllegalStateException: Not locker. lockThread=null
IllegalStateException: Not locker. lockThread=null
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: -- Other --
7.1
All All
: P2 (vote)
: 7.1.1
Assigned To: Miloslav Metelka
issues@editor
EXCEPTIONS_REPORT 71patch1-verified
:
: 217003 221931 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-08 08:09 UTC by namgivu
Modified: 2012-11-12 09:56 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.04 KB, text/plain)
2011-12-08 08:09 UTC, namgivu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description namgivu 2011-12-08 08:09:26 UTC
Build: NetBeans IDE 7.1 RC2 (Build 201111302200)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.0-b11, Java(TM) SE Runtime Environment, 1.6.0_25-b06
OS: Windows 7

User Comments:
namgivu: Hit `tab` on keyboard for two collapsed blocks of html tags cause this crash

GUEST: Runing debugger.

GUEST: A java.lang.NullPointerException exception has occurred.
Please report this at http://www.netbeans.org/community/issues.html,
including a copy of your messages.log file as an attachment.
The messages.log file is located in your C:\Documents and Settings\D_Tr_Kien.NOMANDY-SR2\.netbeans\dev\var\log folder.

GUEST: 1) enabled rectangular selection
2) tried to select block of C code

GUEST: shift-tab on collapsed code segment

GUEST: Trying to delete trailing white space in a wrapped line.




Stacktrace: 
java.lang.IllegalStateException: Not locker. lockThread=null
   at org.netbeans.lib.editor.util.PriorityMutex.unlock(PriorityMutex.java:122)
   at org.netbeans.modules.editor.lib2.view.DocumentView.unlock(DocumentView.java:272)
   at org.netbeans.modules.editor.lib2.view.DocumentView.runTransaction(DocumentView.java:215)
   at org.netbeans.modules.editor.lib2.view.DocumentView$1.run(DocumentView.java:226)
   at org.netbeans.editor.BaseDocument.render(BaseDocument.java:1335)
   at org.netbeans.modules.editor.lib2.view.DocumentView.runReadLockTransaction(DocumentView.java:223)
Comment 1 namgivu 2011-12-08 08:09:28 UTC
Created attachment 113945 [details]
stacktrace
Comment 2 Miloslav Metelka 2011-12-08 16:27:35 UTC
This is a race condition.
Comment 3 Miloslav Metelka 2011-12-08 22:38:43 UTC
I did not find any serious error but in case of InterruptedException catching the code could possibly lead to invalid locking so I've fixed that.

http://hg.netbeans.org/jet-main/rev/b11670ccc29e
Comment 4 Quality Engineering 2011-12-10 12:05:53 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/b11670ccc29e
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #206122 - IllegalStateException: Not locker. lockThread=null
Comment 5 Jiri Prox 2012-02-07 13:21:06 UTC
verified in trunk

namgivu, can you please verify it too, since this is hard to reproduce?
Comment 6 namgivu 2012-02-08 02:53:23 UTC
Yes sure I will
Comment 7 namgivu 2012-02-08 08:13:49 UTC
Which version should I test this? I'm using PHP Netbeans 7.1
Is it okie?
Comment 8 Jiri Prox 2012-02-08 08:17:34 UTC
You have to use daily build - it is available here:
http://bits.netbeans.org/trunk/nightly/2012-02-06_04-00-12/

thanks for your time
Comment 9 Quality Engineering 2012-02-09 02:40:05 UTC
Integrated into 'releases', will be available in build *201202082200* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/00f392a106b2
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #206122 - IllegalStateException: Not locker. lockThread=null
Comment 10 Jiri Prox 2012-02-29 12:20:56 UTC
v.
Comment 11 Milutin Kristofic 2012-10-25 11:54:12 UTC
*** Bug 217003 has been marked as a duplicate of this bug. ***
Comment 12 Milutin Kristofic 2012-11-12 09:56:31 UTC
*** Bug 221931 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo