Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 205943 - Tabs
Tabs
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Window System
7.1
PC Windows 7
: P3 with 2 votes (vote)
: 7.4
Assigned To: Stanislav Aubrecht
issues@platform
:
: 70606 211617 (view as bug list)
Depends on:
Blocks: 223979
  Show dependency treegraph
 
Reported: 2011-12-05 14:54 UTC by suseu
Modified: 2013-04-04 13:31 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
mark up (11.17 KB, image/png)
2011-12-05 15:56 UTC, suseu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description suseu 2011-12-05 14:54:50 UTC
Feature request:
I often have multiple files with the same name opened. It would be nice to have customizable tab name, so it could contain folder name, etc. Option for that could be stored as string like '%FOLDER_NAME%\n%FILE_NAME%'. New line character indicates that the tab name is displayed in two lines.
Also document list invoked with Shift+F4 and Ctrl-Tab could optionally contain folder information.
Please let me know if I can be of some help.
Comment 1 suseu 2011-12-05 15:56:32 UTC
Created attachment 113831 [details]
mark up

I attached mark-up of how I imagine such solution. First line shows file name, the second with smaller font shows parent folder \ folder information. The color bars at the bottom of the tab show color assigned to a project for easier recognition.
Comment 2 Stanislav Aubrecht 2013-02-27 13:41:37 UTC
core-main 996026eea660
Comment 3 markiewb 2013-03-04 22:00:23 UTC
(In reply to comment #2)
> core-main 996026eea660

@Stanislav: Very nice. Thank you.

But are the following options for?
* show full file path (where it is shown?)
* project coloring (i haven't seen any change; several projects were opened)
Comment 4 Stanislav Aubrecht 2013-03-05 09:23:28 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > core-main 996026eea660
> 
> @Stanislav: Very nice. Thank you.
> 
> But are the following options for?
> * show full file path (where it is shown?)
In a small font just below the tabs.

> * project coloring (i haven't seen any change; several projects were opened)
Could be a bug so please file it as such, thanks.
Comment 5 markiewb 2013-03-10 21:45:22 UTC
*** Bug 70606 has been marked as a duplicate of this bug. ***
Comment 6 markiewb 2013-03-10 22:42:12 UTC
*** Bug 211617 has been marked as a duplicate of this bug. ***
Comment 7 markiewb 2013-03-10 22:50:18 UTC
> > But are the following options for?
> > * show full file path (where it is shown?)
> In a small font just below the tabs.
Ok. This works. I had to restart NB to enable the feature.
Comment 8 Stanislav Aubrecht 2013-03-11 09:49:58 UTC
(In reply to comment #7)
> > > But are the following options for?
> > > * show full file path (where it is shown?)
> > In a small font just below the tabs.
> Ok. This works. I had to restart NB to enable the feature.

It should work without restart, I'll fix it.
Comment 9 Stanislav Aubrecht 2013-04-04 13:31:24 UTC
(In reply to comment #7)
> > > But are the following options for?
> > > * show full file path (where it is shown?)
> > In a small font just below the tabs.
> Ok. This works. I had to restart NB to enable the feature.

It should work better now

core-main 20c468df76ce


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo