Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 205914 - No enabled eligible for injection beans are found
No enabled eligible for injection beans are found
Status: RESOLVED DUPLICATE of bug 201825
Product: javaee
Classification: Unclassified
Component: CDI
7.1
PC Linux
: P3 (vote)
: TBD
Assigned To: Denis Anisimov
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-05 06:59 UTC by dwuysan
Modified: 2011-12-06 08:36 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dwuysan 2011-12-05 06:59:54 UTC
Product Version = NetBeans IDE 7.1 RC1 (Build 201111242103)
Operating System = Linux version 3.0.0-12-generic running on amd64
Java; VM; Vendor = 1.7.0_04-ea
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.0-b03

The application works as expected, yet Netbeans shows this warning. Why is this?
Comment 1 Marian Mirilovic 2011-12-05 09:48:19 UTC
Please provide steps to reproduce, attach messages.log and reopen. Thanks in advance.
http://wiki.netbeans.org/FaqLogMessagesFile
Comment 2 dwuysan 2011-12-05 19:22:14 UTC
There is really no need for messages.log (not even sure if it is logged). All that is required is to create a CDI ApplicationScoped bean (in this case, it is also a Singleton EJB), and inject that to a Stateless Session Bean EJB.

At the @Inject injection point of the Stateless Session Bean EJB, this warning displayed in the IDE.

The application runs and behaves as expected.
Comment 3 Martin Fousek 2011-12-06 08:29:42 UTC
Thanks for reporting, reassigning to the correct component.
Comment 4 Denis Anisimov 2011-12-06 08:36:56 UTC
Please read 
http://netbeans.org/bugzilla/show_bug.cgi?id=201825#c6
Your case is the same.
The reason why the application works correctly in runtime : the runtime doesn't
confirm to the CDI spec.

*** This bug has been marked as a duplicate of bug 201825 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo