Bug 205848 - Uninstalable modules on Plugin Portal: Selenium Module for PHP, Selenium Module for Maven
Uninstalable modules on Plugin Portal: Selenium Module for PHP, Selenium Modu...
Status: RESOLVED FIXED
Product: updatecenters
Classification: Unclassified
Component: Pluginportal
7.1
All All
: P1 (vote)
: 7.1
Assigned To: Martin Fousek
issues@updatecenters
: 71_HR_FIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-02 13:47 UTC by Tomas Danek
Modified: 2012-01-02 06:36 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2011-12-02 13:47:23 UTC
Product Version: NetBeans IDE 7.1 (Build 201112012200)
Java: 1.6.0_29; Java HotSpot(TM) 64-Bit Server VM 20.4-b02-402
System: Mac OS X version 10.6.8 running on x86_64; MacRoman; en_US (nb)
User directory: /Users/Tomas/.netbeans/7.1
Cache directory: /Users/Tomas/.netbeans/7.1/var/cache
---------------------------------
Tried to install all from UCs registered in build above

Some plugins require plugin org.netbeans.modules.selenium.server to be installed.
The plugin org.netbeans.modules.selenium.server is requested in version 1.3.  
The following plugins are affected:       

Selenium Module for Maven       
Selenium Module for PHP
Comment 1 Jiri Kovalsky 2011-12-02 14:44:48 UTC
Martine, are you able to fix dependencies so that these two plugins can be installed into 6.9, 7.0 and 7.1, rebuild the plugin, publish to Plugin Portal and ask for verification. Is this doable in the foreseeable future?
Comment 2 Martin Fousek 2011-12-02 15:08:02 UTC
The problem is not probably in dependencies but in the fact, that Selenium Server didn't passed verification from user community, so there is this dependency missing now. :/

My proposal: I will dismiss verifications of Selenium Module for Maven and Selenium Module for PHP. It will fix this P1 and I will request for reverification for NB7.1 in time when I'll fix bugs mentioned by verificators. Do you agree?
Comment 3 Jiri Kovalsky 2011-12-02 15:17:10 UTC
Yes, I agree. Remove the verifications until Selenium Server plugin is fixed according to comments from Plugin Verifiers team.
Comment 4 Martin Fousek 2011-12-02 15:28:10 UTC
Ok, I deleted verifications for two remaining modules until the main dependency "Selenium Server" will pass the verification process. 

See:
http://plugins.netbeans.org/plugin/37746
http://plugins.netbeans.org/plugin/37753

Closing as fixed.
Comment 5 Tomas Danek 2011-12-02 15:41:20 UTC
Martine, Jirko - please let me know once I'm able to start verification. I guess that catalog need to be regenerated, right?
Comment 6 Jiri Kovalsky 2011-12-02 15:42:54 UTC
Thanks Martine. Selenium plugins are no longer offered in Available Plugins tab.
Comment 7 lynx.ripe 2011-12-30 09:23:07 UTC
Hello!

  IMHO it's a pity that the Selenium Module for PHP has been made unavailable for NB 7.1 due to the fact that Selenium Server didn't pass verification from user community. Actually there is no need to hardwire the "Selenium Module for PHP -> Selenium Server" dependency _at all_, since the module is perfectly usable with the remote Selenium RC Server(s) started on _another_ host(s) (not one that is running NB). phpunit.xml in this case refers to the remote host(s) like this:

<selenium>
        <browser name="Firefox on the Linux host"
           browser="*firefox"
           host="vb-test" port="4444" timeout="20" />
</selenium>

and NB-supplied Selenium Server can be safely disabled using the Services -> Servers -> Selenium Server Properties.
  So I vote for the "Selenium Module for PHP -> Selenium Server" dependency removal, and for the "Selenium Module for PHP" return to the Available Plugins
tab list.

Sincerely, Dmytro
Comment 8 Jiri Kovalsky 2012-01-01 17:50:28 UTC
OK. Martine, any estimate on when you could fix the Selenium Server plugin visibility?
Comment 9 Martin Fousek 2012-01-02 06:36:47 UTC
To Dmytro: Right, there is no need for that dependency. I just preserve the behaviour designed by first author of the module, but it can be changed of course.

Dmytro, Jirka it is really not hard to fix these 2 issues. But since the most work is actually do that against old sources (release69 branch) and pass rest of processes to get these modules verified, signed into Plugin Portal UC, I would like to fix there as much issues as possible at one moment. Hopefully I could take a look on that next week.

Anyway I think that the reason for reopening does not belong into this issue but probably into some new issue of Contrib/Selenium category - especially since the original problem could be stopper for 7.1 and was resolved by removing verification on those plugins. Dmytro I promise you that I'll try to take a look on that ASAP.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo