Bug 205635 - [71cat] com.sun.jdi.InvalidStackFrameException: Thread has been resumed
[71cat] com.sun.jdi.InvalidStackFrameException: Thread has been resumed
Status: RESOLVED FIXED
Product: debugger
Classification: Unclassified
Component: Java
7.1
All All
: P3 (vote)
: 7.4
Assigned To: Martin Entlicher
issues@debugger
EXCEPTIONS_REPORT
: RANDOM, THREAD
: 205611 205642 219895 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-29 08:57 UTC by williambacchi
Modified: 2013-07-25 12:18 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.72 KB, text/plain)
2011-11-29 08:57 UTC, williambacchi
Details
stacktrace (2.66 KB, text/plain)
2012-07-13 17:17 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description williambacchi 2011-11-29 08:57:53 UTC
This bug was originally marked as duplicate of bug 141061, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.1 RC1 (Build 201111242103)
VM: Java HotSpot(TM) Client VM, 17.1-b03, Java(TM) SE Runtime Environment, 1.6.0_22-b04
OS: Windows XP

Stacktrace: 
com.sun.jdi.InvalidStackFrameException: Thread has been resumed
   at com.sun.tools.jdi.StackFrameImpl.validateStackFrame(StackFrameImpl.java:62)
   at com.sun.tools.jdi.StackFrameImpl.thisObject(StackFrameImpl.java:111)
   at org.netbeans.modules.debugger.jpda.expr.EvaluationContext.getContextObject(EvaluationContext.java:183)
   at org.netbeans.modules.debugger.jpda.expr.EvaluatorVisitor.getIdentifierByName(EvaluatorVisitor.java:1700)
   at org.netbeans.modules.debugger.jpda.expr.EvaluatorVisitor.visitIdentifier(EvaluatorVisitor.java:1804)
   at org.netbeans.modules.debugger.jpda.expr.EvaluatorVisitor.visitIdentifier(EvaluatorVisitor.java:194)
Comment 1 williambacchi 2011-11-29 08:57:56 UTC
Created attachment 113603 [details]
stacktrace
Comment 2 Martin Entlicher 2011-11-29 09:13:58 UTC
*** Bug 205611 has been marked as a duplicate of this bug. ***
Comment 3 Martin Entlicher 2011-11-29 09:51:58 UTC
Steps to reproduce are required to fix this.
According to the logs, the thread in question is suspended, so it's not apparent where is the problem.
Comment 4 Martin Entlicher 2012-05-31 14:13:21 UTC
*** Bug 205642 has been marked as a duplicate of this bug. ***
Comment 5 Exceptions Reporter 2012-07-13 17:17:06 UTC
Created attachment 122019 [details]
stacktrace
Comment 6 Martin Entlicher 2012-10-19 08:03:42 UTC
*** Bug 219895 has been marked as a duplicate of this bug. ***
Comment 7 Martin Entlicher 2012-10-19 08:05:46 UTC
This seems to occur on JDK 1.6 only. Therefore it's likely fixed in JDK 1.7.
Comment 8 Martin Entlicher 2013-07-25 12:18:51 UTC
NetBeans 7.4 runs only on JDK 7 and newer. Thus it's fixed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo