Bug 205583 - NetBeans 7.1rc1 breaks Russian text
NetBeans 7.1rc1 breaks Russian text
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Editor
7.0
All All
: P2 (vote)
: 7.1
Assigned To: Alexander Simon
issues@cnd
701patch-candidate
: 71_HR_FIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-27 10:46 UTC by soldatov
Modified: 2012-05-14 13:48 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description soldatov 2011-11-27 10:46:51 UTC
Scenario:
- Create C/C++ application
- Add any Russian comment into main.cpp. For example:
// привет
- Restart IDE
===>
"The file cannot be safely opened with UTF-8" window appears
Comment 1 soldatov 2011-11-27 10:47:41 UTC
IDE saves file in Windows-1251 instead of UTF-8
Comment 2 soldatov 2011-11-28 09:17:38 UTC
same problem in NB7.1 rc1
Comment 3 soldatov 2011-11-29 09:21:35 UTC
7.0.1 works nicely in same scenario
Comment 4 Vladimir Voskresensky 2011-11-29 14:09:03 UTC
Sasha, please, have a look
Comment 5 Alexander Simon 2011-11-29 14:36:04 UTC
fixed, change set:
http://hg.netbeans.org/cnd-main/rev/fbb0c5403915
Comment 6 Alexander Simon 2011-11-29 14:45:37 UTC
Vladimir: please review the fix.
Comment 7 Vladimir Kvashin 2011-11-29 16:04:51 UTC
I reviewed the fix, it is correct and safe.
Comment 8 Vladimir Kvashin 2011-11-29 16:19:38 UTC
I've set "701patch-candidate" because it's a regression that is already in blacktie branch

transplanted into blacktie:
rev/538c7a3dbdb7
Comment 9 soldatov 2011-11-30 07:59:39 UTC
verified on windows with UTF-8 and Windows-1251 encoding in managed and unmanaged projects
Comment 10 Vladimir Kvashin 2011-11-30 14:11:55 UTC
Transplanted to releases71:
http://hg.netbeans.org/releases/rev/186fbe956c3e
Comment 11 Quality Engineering 2011-12-01 07:05:54 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/186fbe956c3e
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #205583 NetBeans 7.1rc1 breaks Russian text
(transplanted from fbb0c5403915a1de160ab8102710b7c073b31920)
Comment 12 soldatov 2011-12-02 12:53:47 UTC
verified in NetBeans IDE 7.1 (Build 201112012200)
Comment 13 Quality Engineering 2011-12-08 12:10:18 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/fbb0c5403915
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #205583 NetBeans 7.1rc1 breaks Russian text
Comment 14 Alexander Pepin 2012-05-14 13:48:14 UTC
verified in NB 7.0.1 patch3 candidate (build 201205021427)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo