Bug 205566 - Moving source file fails
Moving source file fails
Status: CLOSED DUPLICATE of bug 203477
Product: editor
Classification: Unclassified
Component: -- Other --
7.1
PC Windows 7
: P2 (vote)
: 7.1
Assigned To: Milutin Kristofic
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-25 16:22 UTC by tim_sa
Modified: 2011-12-07 09:48 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tim_sa 2011-11-25 16:22:36 UTC
[ BUILD # : 201111171527 ]
[ JDK VERSION : 1.7 ]

1) File -> New File -> Java Class
2) package name : mypackage
3) Finish
4) Line 5: change mypackage to mypackage.aa
5) Click lightbulb
6) select 'Move to correct Folder'

Dialog box appears "File was modified externally. Reload it?"

Select yes:
The file moves the folder mypackage/aa but the package statement reverts to
mypackage

Select no:
the File moves to mypackage/aa and the package statement is mypackage.aa
Comment 1 tim_sa 2011-11-25 17:45:33 UTC
goo.gl/O0yDX
above URL shortened
Comment 2 tim_sa 2011-11-25 17:46:30 UTC
please ignore previous comment
Comment 3 MackSix 2011-11-25 19:17:05 UTC
I can reproduce this when 2 projects are open.


Product Version: NetBeans IDE 7.1 RC1 (Build 201111171527)
Java: 1.7.0_01; Java HotSpot(TM) Client VM 21.1-b02
System: Windows Vista version 6.0 running on x86; Cp1252; en_US (nb)
Comment 4 tim_sa 2011-11-29 15:03:08 UTC
Still reproducible in 201111242103
Comment 5 Jiri Kovalsky 2011-11-29 19:25:11 UTC
Can someone please evaluate this? Seems like a duplicate of issue #203477.
Comment 6 Milutin Kristofic 2011-11-30 10:44:29 UTC
I cannot reproduce it on 201111270600.

Can you try a new build, please? - After 2011-11-29 since Issue #203477 was fixed that day.
Comment 7 tim_sa 2011-11-30 12:18:58 UTC
This looks to be resolved in 201111290600

*** This bug has been marked as a duplicate of bug 203477 ***
Comment 8 Marian Mirilovic 2011-12-07 09:48:46 UTC
v/c


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo