Bug 205558 - Automatic FX platform creation during project opening doesn't work in some cases with FOD
Automatic FX platform creation during project opening doesn't work in some ca...
Status: RESOLVED DUPLICATE of bug 203220
Product: javafx
Classification: Unclassified
Component: Platform
7.1
PC Windows 7
: P2 (vote)
: 7.2
Assigned To: Anton Chechel
issues@javafx
: ERGONOMICS, RELNOTE
Depends on: 203220
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-25 11:12 UTC by Stepan Zebra
Modified: 2012-01-20 13:18 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stepan Zebra 2011-11-25 11:12:19 UTC
#205341 related

During final RC1 verification round (build 201111242103), I noticed that the automatic platform creation during project opening is somehow dependent on FOD.

In JavaSE, JavaEE and All (without FOD) installer packs, it works fine.

In All (with FOD) installer pack, it works fine when no features are activated in the IDE, but fails in situations when JavaSE pack is already activated in the IDE. In this case, the FX support is activated during project opening, but no platform is created and Reference Problem dialog shows up. Same error happens when both JavaSE and JavaFX are already activated, but no FX enabled platform is available, before opening first external FX project.
Comment 1 Anton Chechel 2011-11-28 18:16:27 UTC
Ergonomics due to some unknown reason do not invoke OpenedProjectHook for JavaFX when J2SE is already activated.

Steps to reproduce:
1. Remove userdir.
2. Start NB.
3. Open existing FX project.
4. Goto platform manager - Default JavaFX Platform is registered: correct.
5. Exit NB.
6. Remove userdir.
7. Start NB
8. Invoke "New - Java Project" wizard.
9. Java SE is been activated, but not JavaFX (which is correct).
10. Cancel Java project creation.
11. Open existing JavaFX project.
12. Goto platform manager - no Default JavaFX Platform is registered: incorrect.

Obviously ide.ergonomics/javafx.properties is not taken into account by ergonomics after step 7.

Will ask Jarda tomorrow.
Comment 2 Stepan Zebra 2011-11-29 16:10:53 UTC
According to Jarda, fix in ergonomics would be too complex and risky. So I'm removing the 71_HR_FIX_CANDIDATE keyword and setting TM to 7.2 for now.

The issue is not critical, but still a high priority, because in the use cases stated in the issue Description, the Automatic FX platform creation is not invoked and Reference Problem dialog shows up.

The issue was found after 7.1 cutoff, but it's a problem that arose due to 7.1 HR fix of issue 205341 so I'm not sure if there is a need for the waiver process.
Comment 3 Anton Chechel 2011-11-29 16:38:27 UTC
This issue will be fixed with #202344.
Setting milestone to 7.2
Comment 4 Anton Chechel 2011-11-29 16:39:15 UTC
I mean partially fixed - on FX side, not ergonomics.
Comment 5 Stepan Zebra 2012-01-02 14:36:31 UTC
Problem is resolved in Dev build 201201010601, after the fix of issue 203220
Are there any other actions required on FX side to complete this issue?
If not and fix of issue 203220 will make it to the 7.1 patch 1, then this issue can be marked as fixed for 7.1.1.
Comment 6 Jaroslav Tulach 2012-01-05 17:51:51 UTC
> Are there any other actions required on FX side to complete this issue?

No. Now the issue can be seen as duplicate of 203220.
Comment 7 Anton Chechel 2012-01-20 13:18:26 UTC

*** This bug has been marked as a duplicate of bug 203220 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo