Bug 205535 - NetBeans with JRE: problem after installing plugins that require JDK
NetBeans with JRE: problem after installing plugins that require JDK
Status: NEW
Product: platform
Classification: Unclassified
Component: Plugin Manager
7.1
PC Linux
: P4 (vote)
: TBD
Assigned To: Libor Fischmeistr
au-issues
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-24 17:35 UTC by Vladimir Riha
Modified: 2014-02-10 14:16 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
ide log (5.96 KB, text/x-log)
2011-11-24 17:35 UTC, Vladimir Riha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2011-11-24 17:35:32 UTC
Created attachment 113513 [details]
ide log

Steps to reproduce:
- download PHP bundle, run it with JDK
- download/install plugin Java (will also download Ant and Java Profiler)
- restart NB after installation
- deactivate those 3 plugins
- restart NB, close NB
- run NB on JRE
- Error msg is shown that "The JDK is missing and is required to run some NetBeans modules". Choices either Exit or Disable Modules and Continue, choose "Disable and..."
=> Assertion Error

JDK 1.7.0_02 (and it's JRE) used.

Product Version         = NetBeans IDE Dev (Build 201111240600) (#53d2baca3d39)
Operating System        = Linux version 3.0.0-12-generic-pae running on i386
Java; VM; Vendor        = 1.7.0_02; Java HotSpot(TM) Client VM 22.0-b10; Oracle Corporation


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo