Bug 205418 - MinGW + Msys: debugger ignores line breakpoints
MinGW + Msys: debugger ignores line breakpoints
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Debugger
7.1
PC Windows XP
: P2 (vote)
: 7.1
Assigned To: Egor Ushakov
issues@cnd
: 71_HR_FIX
: 205708 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-22 12:07 UTC by soldatov
Modified: 2011-12-01 13:55 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
gdb log (4.54 KB, text/plain)
2011-11-22 12:07 UTC, soldatov
Details
gdb log (NB7.0.1 works nicely) (4.52 KB, text/plain)
2011-11-24 08:20 UTC, soldatov
Details
gdb log (NB7.1 doesn't work) (3.98 KB, text/plain)
2011-11-24 08:21 UTC, soldatov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description soldatov 2011-11-22 12:07:45 UTC
Created attachment 113409 [details]
gdb log

MinGW + Msys
Scenario:
- Create Quote project
- Set line breakpoint at 121th line
- Push Debug Main Project button
===> debugger ignores line breakpoint
Comment 1 soldatov 2011-11-22 12:27:34 UTC
P.S. Debugger works nicely if project is created in C:/Document and Settings and fails if project is created in C:/tmp
Comment 2 soldatov 2011-11-24 08:20:32 UTC
Created attachment 113496 [details]
gdb log (NB7.0.1 works nicely)
Comment 3 soldatov 2011-11-24 08:21:37 UTC
Created attachment 113497 [details]
gdb log (NB7.1 doesn't work)
Comment 4 soldatov 2011-11-24 08:22:25 UTC
35a36,37
> 13-break-insert -f "/C/tmp/Quote_1/quote.cc:119"
> 14-break-insert -t _start
47,52c49,50
< 13-break-insert -f "C:/tmp/Quote_1/quote.cc:119"
< 1
< 13^done,bkpt={number="1",type="breakpoint",disp="keep",enabled="y",addr="0x00402540",func="main",file="quote.cc",fullname="C:\\tmp\\Quote_1/quote.cc",line="119",times="0"}
< (gdb) 
< &"\n"
< 1^done
---
> &"No source file named /C/tmp/Quote_1/quote.cc in loaded symbols.\n"
> 13^done,bkpt={number="1",type="breakpoint",disp="keep",enabled="y",addr="<PENDING>",pending="/C/tmp/Quote_1/quote.cc:119",times="0"}
54,55d51
diff gdb_nb701.txt gdb_nb71.txt

< 14-break-insert -t _start
< No command for record 1^done
65c61
< ~"[New thread 828.0x8dc]\n"
---
> ~"[New thread 328.0xc38]\n"
70c66
< ~"* 1 thread 828.0x8dc  main (argc=1, argv=0x3e2c10) at quote.cc:118\n"
---
> ~"* 1 thread 328.0xc38  main (argc=1, argv=0x3e2c10) at quote.cc:118\n"
76,83d71
< 18*stopped,reason="breakpoint-hit",bkptno="1",thread-id="1",frame={addr="0x00402540",func="main",args=[{name="argc",value="1"},{name="argv",value="0x3e2c10"}],file="quote.cc",fullname="C:\\tmp\\Quote_1/quote.cc",line="119"}
< (gdb) 
< 19-stack-list-frames
< 19^done,stack=[frame={level="0",addr="0x00402540",func="main",file="quote.cc",fullname="C:\\tmp\\Quote_1/quote.cc",line="119"}]
< (gdb) 
< 20-stack-list-arguments 1
< 20^done,stack-args=[frame={level="0",args=[{name="argc",value="1"},{name="argv",value="0x3e2c10"}]}]
< (gdb)
Comment 5 Egor Ushakov 2011-11-25 09:21:57 UTC
fixed in trunk:
http://hg.netbeans.org/cnd-main/rev/9d81aad71afb
Comment 6 soldatov 2011-11-25 11:53:29 UTC
Ok. I verified fix on 3 machines (4 different configurations).
Comment 7 Quality Engineering 2011-11-27 17:00:17 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/9d81aad71afb
User: Egor Ushakov <gorrus@netbeans.org>
Log: fixed #205418 (MinGW + Msys: debugger ignores line breakpoints)
Comment 8 Vladimir Voskresensky 2011-11-28 15:35:45 UTC
Fix is reviewed. I consider it to be correct,
Some cosmetic comments: commented out code is better to be removed and "sometimes" in comment have to be removed as well as soon as mingw's gdb understand only C:/..../ path formats
Comment 9 Egor Ushakov 2011-11-29 10:29:57 UTC
comments corrected:
http://hg.netbeans.org/cnd-main/rev/6683913fe889
Comment 10 Egor Ushakov 2011-11-29 16:01:13 UTC
integrated into release71 with:
http://hg.netbeans.org/releases/rev/3dcf73ef0d34
Comment 11 Quality Engineering 2011-11-30 07:12:18 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/3dcf73ef0d34
User: Egor Ushakov <gorrus@netbeans.org>
Log: fixed #205418(MinGW + Msys: debugger ignores line breakpoints)
Comment 12 Marian Mirilovic 2011-12-01 10:52:55 UTC
*** Bug 205708 has been marked as a duplicate of this bug. ***
Comment 13 Quality Engineering 2011-12-01 12:08:51 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/6683913fe889
User: Egor Ushakov <gorrus@netbeans.org>
Log: fixed comments for #205418(MinGW + Msys: debugger ignores line breakpoints)
Comment 14 soldatov 2011-12-01 13:55:51 UTC
Verified in NetBeans IDE 7.1 RC2 (Build 201111302200)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo