Bug 205399 - Bad folder name from FTP Import with PHp Project
Bad folder name from FTP Import with PHp Project
Status: VERIFIED FIXED
Product: php
Classification: Unclassified
Component: FTP Support
7.1
All All
: P1 (vote)
: 7.1
Assigned To: Tomas Mysik
issues@php
: 71_HR_FIX
: 205327 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-22 01:59 UTC by Nanowish
Modified: 2012-05-30 14:18 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
output of nb 7.2 (nightly) showing an error (1.38 KB, text/plain)
2012-05-30 08:59 UTC, hurrtz
Details
project properties of netbeans project (17.38 KB, image/png)
2012-05-30 10:01 UTC, hurrtz
Details
remote connection properties of ftp-connection (13.68 KB, image/png)
2012-05-30 10:02 UTC, hurrtz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nanowish 2011-11-22 01:59:59 UTC
Product Version = NetBeans IDE 7.1 Beta (Build 201109252201)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.7.0
Runtime = Java HotSpot(TM) 64-Bit Server VM 21.0-b17

Hi,
When I create new PHP Project from remote source with FTP, the first character of files folder is removed.
Ex: admin becomes dmin


CWD //admin
250 Directory successfully changed.
PORT 192,168,1,36,215,28
200 PORT command successful. Consider using PASV.
RETR updates.php
150 Opening BINARY mode data connection for updates.php (2078 bytes).
226 File send OK.

Succeeded:
file      about.php
file      action.php
dir       admin <---- CORRECT ADMIN FOLDER !!
file      admin.php
file      alleries/index.php
file      anguage/index.php
file      category.php
file      comments.php
file      dmin/batch_manager.php
[...]
file      dmin/updates.php  <----- BAD ADMIN FOLDER FOR FILES!!! dmin/updates.php instead of admin/updates.php
Comment 1 Tomas Mysik 2011-11-22 08:50:46 UTC
@reporter: Can you, please, try the development version of NetBeans [1]? If you can reproduce, can you please tell us what is your Initial Directory [2] and Upload Directory [3]?

@Láďa: Can you please try to reproduce this issue?

Thanks a lot.
Comment 2 Tomas Mysik 2011-11-22 08:51:56 UTC
Sorry, forgot to add links:

[1] http://bits.netbeans.org/download/trunk/nightly/latest/
[2] in Manage Remote COnnections dialog
[3] in Project Properties > Run Configuration dialog
Comment 3 Tomas Mysik 2011-11-22 08:52:22 UTC
*** Bug 205327 has been marked as a duplicate of this bug. ***
Comment 4 Tomas Mysik 2011-11-22 09:04:19 UTC
I can reproduce it, thanks for catching that. Will fix ASAP.
Comment 5 Tomas Mysik 2011-11-22 09:57:15 UTC
This bug happens only for "/" as a base remote directory.

Should be fixed now, Láďo, please verify [1] so I can backport it to NB 7.1 branch.

http://hg.netbeans.org/web-main/rev/e40d004698b4

Thanks.
[1] Please, verify both, "/" as well as "/mydir" base remote directories.
Comment 6 Tomas Mysik 2011-11-22 09:58:09 UTC
TM is 7.2, will be changed after backporting.
Comment 7 Vladimir Riha 2011-11-22 11:16:59 UTC
verified, files/folders aren't being renamed.

Product Version: NetBeans IDE Dev (Build 2011-11-22_10-55-51 )
Java: 1.7.0_02; Java HotSpot(TM) Client VM 22.0-b10
System: Linux version 3.0.0-12-generic-pae running on i386; UTF-8; en_US (nb)
Comment 8 Tomas Mysik 2011-11-23 09:34:20 UTC
Transplanted to the 7.1 branch, please verify. Thanks.

http://hg.netbeans.org/releases/rev/47821a74c4a5
Comment 9 Quality Engineering 2011-11-23 15:58:34 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/e40d004698b4
User: Tomas Mysik <tmysik@netbeans.org>
Log: #205399 - Bad folder name from FTP Import with PHp Project
Comment 10 Quality Engineering 2011-11-24 07:15:44 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/47821a74c4a5
User: Tomas Mysik <tmysik@netbeans.org>
Log: #205399 - Bad folder name from FTP Import with PHp Project
(transplanted from e40d004698b49edc53e45048f4ac16101ffe9ce4)
Comment 11 Vladimir Riha 2011-11-24 11:18:04 UTC
Verified in RC1

Product Version: NetBeans IDE 7.1 RC1 (Build 201111232200)
Java: 1.7.0_02; Java HotSpot(TM) Client VM 22.0-b10
System: Linux version 3.0.0-12-generic-pae running on i386; UTF-8; en_US (nb)
Comment 12 hurrtz 2012-05-30 08:59:01 UTC
Created attachment 120053 [details]
output of nb 7.2 (nightly) showing an error
Comment 13 hurrtz 2012-05-30 09:15:41 UTC
The reported error still persists, even when using the nightly build of Netbeans 7.2, which is currently 201205300001.

I have attached the output of Netbeans to this bug report. There you can see the problem at the end of the file:
"CWD /var/kunden/webs/blaudirekt/portal/vermittler/unde" -> this is faulty, as it should be
"CWD /var/kunden/webs/blaudirekt/portal/vermittler/kunde".

If you need additional information please let me know.
Comment 14 Tomas Mysik 2012-05-30 09:43:11 UTC
@hurrtz: Please, provide screen shots of your:
- remote server configuration [1]
- remote web configuration [2]

Thanks.
[1] in Manage Remote Connections dialog
[2] Project Properties > Run Configuration dialog
Comment 15 Tomas Mysik 2012-05-30 09:45:19 UTC
@hurrtz: Also, please provide exact steps to reproduce (download? upload? ...?).

Thanks.
Comment 16 hurrtz 2012-05-30 10:01:25 UTC
Created attachment 120057 [details]
project properties of netbeans project
Comment 17 hurrtz 2012-05-30 10:02:07 UTC
Created attachment 120058 [details]
remote connection properties of ftp-connection
Comment 18 hurrtz 2012-05-30 10:10:29 UTC
I have uploaded screenshots for [1] and [2].

Basic environment: I have a webspace on a server which is accessed via sftp in Netbeans. Those files are mirrored on my computer. The Netbeans-project refers to the files on my computer and is ordered to update the files on my webspace on save-command.

As for the reproduceability:
- make a change in a file
- save the file (Netbeans is supposed to upload the file to the server)
Comment 19 Tomas Mysik 2012-05-30 10:11:18 UTC
Does the upload-on-save work for you? I see "Missing connection" in the dialog...

Thanks.
Comment 20 Tomas Mysik 2012-05-30 10:13:12 UTC
@vriha: Láďo, please try to reproduce this issue.

Thanks.
Comment 21 hurrtz 2012-05-30 10:31:10 UTC
I am sorry, somehow that went wrong... Normally the remote connection would have been selected (otherwise saving would not work).
Comment 22 Tomas Mysik 2012-05-30 14:18:56 UTC
I have filed issue #213245 - please provide your comments there.

Thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo