Bug 205372 - Starting Profiling session for Applet fails
Starting Profiling session for Applet fails
Status: VERIFIED FIXED
Product: profiler
Classification: Unclassified
Component: Ide
7.1
All Mac OS X
: P1 (vote)
: 7.1
Assigned To: Tomas Hurka
issues@profiler
: 71_HR_FIX, REGRESSION
: 205407 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-21 17:14 UTC by michal.owsiak
Modified: 2011-11-25 06:17 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description michal.owsiak 2011-11-21 17:14:38 UTC
Use-case:


http://wiki.netbeans.org/TS_71_Profiler
3.1	 Profile Applet - AppletViewer


java.util.MissingResourceException: Can't find resource for bundle org.openide.util.NbBundle$PBundle, key GEN_title
	at java.util.ResourceBundle.getObject(ResourceBundle.java:374)
	at java.util.ResourceBundle.getString(ResourceBundle.java:334)
	at org.netbeans.modules.profiler.projectsupport.utilities.AppletSupport.fillInFile(AppletSupport.java:218)
	at org.netbeans.modules.profiler.projectsupport.utilities.AppletSupport.generateHtml(AppletSupport.java:317)
	at org.netbeans.modules.profiler.projectsupport.utilities.AppletSupport.generateHtmlFileURL(AppletSupport.java:118)
	at org.netbeans.modules.profiler.nbimpl.project.ProjectUtilities.generateAppletHTML(ProjectUtilities.java:707)
	at org.netbeans.modules.profiler.j2se.J2SEProjectProfilingSupportProvider.configurePropertiesForProfiling(J2SEProjectProfilingSupportProvider.java:214)
	at org.netbeans.modules.profiler.api.project.ProjectProfilingSupport.configurePropertiesForProfiling(ProjectProfilingSupport.java:126)
	at org.netbeans.modules.profiler.nbimpl.actions.AntActions$8.run(AntActions.java:739)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1411)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1991)
Caused: org.openide.util.RequestProcessor$SlowItem: task failed due to
	at org.openide.util.RequestProcessor.post(RequestProcessor.java:428)
	at org.netbeans.modules.profiler.nbimpl.actions.AntActions$9$1.run(AntActions.java:760)
	at org.netbeans.api.java.source.ui.ScanDialog.runWhenScanFinished(ScanDialog.java:153)
	at org.netbeans.modules.profiler.nbimpl.actions.AntActions$9.run(AntActions.java:757)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:677)
	at java.awt.EventQueue.access$000(EventQueue.java:85)
	at java.awt.EventQueue$1.run(EventQueue.java:638)
	at java.awt.EventQueue$1.run(EventQueue.java:636)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:647)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:162)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
[catch] at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
Comment 1 Tomas Hurka 2011-11-21 20:38:33 UTC
Next time, please provide NetBeans build number and attach thread dump instead of pasting it to the description field. Thanks.
Comment 2 Tomas Hurka 2011-11-21 20:50:16 UTC
Fixed in profiler-main

changeset:   207589:c14d60a8c043
user:        Tomas Hurka <thurka@netbeans.org>
date:        Mon Nov 21 21:33:47 2011 +0100
summary:     bugfix #205372, GEN_ bundle keys moved to profiler.projectsupport module
Comment 3 Petr Cyhelsky 2011-11-22 09:30:27 UTC
*** Bug 205407 has been marked as a duplicate of this bug. ***
Comment 4 Quality Engineering 2011-11-23 15:59:13 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/c14d60a8c043
User: Tomas Hurka <thurka@netbeans.org>
Log: bugfix #205372, GEN_ bundle keys moved to profiler.projectsupport module
Comment 5 Petr Cyhelsky 2011-11-24 08:08:06 UTC
verified on:
Product Version: NetBeans IDE Dev (Build 201111230600)
Java: 1.7.0_02; Java HotSpot(TM) 64-Bit Server VM 22.0-b10
System: Linux version 2.6.38-12-generic running on amd64; UTF-8; en_US (nb)
Comment 6 J Bachorik 2011-11-24 09:17:46 UTC
Fix reviewed - OK
Comment 7 Tomas Hurka 2011-11-24 16:54:28 UTC
Merged to release71 branch.

changeset:   214221:86144453486f
branch:      release71
parent:      214215:f7b0d1285982
user:        Tomas Hurka <thurka@netbeans.org>
date:        Mon Nov 21 21:33:47 2011 +0100
summary:     bugfix #205372, GEN_ bundle keys moved to profiler.projectsupport module
Comment 8 Quality Engineering 2011-11-25 06:17:58 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/86144453486f
User: Tomas Hurka <thurka@netbeans.org>
Log: bugfix #205372, GEN_ bundle keys moved to profiler.projectsupport module
(transplanted from c14d60a8c04395a8484748d05d0858c208c9a3d9)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo