Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 205340 - [71cat] cannot start GlassFish out of NB
[71cat] cannot start GlassFish out of NB
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: GlassFish
7.2
PC Windows XP
: P1 (vote)
: 7.2
Assigned To: Vince Kraemer
issues@serverplugins
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-21 09:07 UTC by muellermi
Modified: 2011-11-30 14:28 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
<no description> (73.61 KB, text/plain)
2011-11-21 09:08 UTC, muellermi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description muellermi 2011-11-21 09:07:40 UTC
Product Version = NetBeans IDE Dev (Build 201111200600)
Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.7.0_01
Runtime = Java HotSpot(TM) Client VM 21.1-b02

First, it seemed, a former bug is back:

In services, open Servers. Right click your local GlassFish. All StartXXX items are disabled.
Then, after starting GklassFish from prompt, it's status is refreshed in NB.

Now, it is possible to stop and start from within NB (which is different to the former bug).
Comment 1 muellermi 2011-11-21 09:08:03 UTC
Created attachment 113358 [details]
<no description>
Comment 2 muellermi 2011-11-21 12:05:26 UTC
Cannot start out ouf services tree view.
But if I start a web application, GF will be started automatically.
Decreasing priority P2 -> P3
Comment 3 Jiri Skrivanek 2011-11-21 12:20:30 UTC
I can confirm that Start menu items are disabled when you register GlassFish
server in dev (7.2) build. I can't reproduce it in 7.1 RC build. I think it deserves immediate investigation because it is a regression and other features might be impacted as well.
Comment 4 Vince Kraemer 2011-11-21 18:45:42 UTC
found the problem. this should have been part of http://hg.netbeans.org/web-main/rev/46f6290801be.

http://hg.netbeans.org/web-main/rev/c46dc8ae89a8
Comment 5 Quality Engineering 2011-11-22 15:52:18 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/c46dc8ae89a8
User: vince kraemer <vkraemer@netbeans.org>
Log: #205340 : missed the transition from state UNKNOWN to state STOPPED in refresh(String,String)
Comment 6 Vince Kraemer 2011-11-23 20:39:19 UTC
in the build
Comment 7 David Konecny 2011-11-24 02:16:55 UTC
Works in latest dev build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo