Bug 205339 - Reset collected results button is disabled
Reset collected results button is disabled
Status: VERIFIED FIXED
Product: profiler
Classification: Unclassified
Component: Ide
7.1
PC Windows 7
: P1 (vote)
: 7.1
Assigned To: Tomas Hurka
issues@profiler
: 71_HR_FIX, REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-21 08:01 UTC by Petr Cyhelsky
Modified: 2011-11-29 08:46 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Cyhelsky 2011-11-21 08:01:14 UTC
Product Version: NetBeans IDE 7.1 RC1 (Build 201111171527)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b18
System: Windows 7 version 6.1 running on x86; Cp1252; en_US (nb)

Trying to profile, both reset collected results buttons stay disabled no matter what is done.
Comment 1 Tomas Hurka 2011-11-25 15:15:23 UTC
This is probably caused by 29cb4f37f1aa. Listener instances obtained from lookup must be held in memory because they have non-null delegate. The current implementation does not do it.
Comment 2 Tomas Hurka 2011-11-25 15:17:57 UTC
Fixed in profiler-main.

changeset:   207807:d9a54fb80b17
user:        Tomas Hurka <thurka@netbeans.org>
date:        Fri Nov 25 16:04:28 2011 +0100
summary:     bugfix #205339, make sure listeners are not GCed
Comment 3 Quality Engineering 2011-11-27 17:00:11 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/d9a54fb80b17
User: Tomas Hurka <thurka@netbeans.org>
Log: bugfix #205339, make sure listeners are not GCed
Comment 4 Petr Cyhelsky 2011-11-28 08:34:31 UTC
verified on:
Product Version: NetBeans IDE Dev (Build 201111270600)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b18
System: Windows 7 version 6.1 running on x86; Cp1252; en_US (nb)
Comment 5 J Bachorik 2011-11-28 09:18:52 UTC
Fix reviewed. May be integrated into release71 branch.
Comment 6 Tomas Hurka 2011-11-28 16:21:47 UTC
Transplanted to release71 branch.

changeset:   214404:200493b7c808                                                                                                                                        
branch:      release71
user:        Tomas Hurka <thurka@netbeans.org>
date:        Fri Nov 25 16:04:28 2011 +0100
summary:     bugfix #205339, make sure listeners are not GCed
Comment 7 Quality Engineering 2011-11-29 08:46:13 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/200493b7c808
User: Tomas Hurka <thurka@netbeans.org>
Log: bugfix #205339, make sure listeners are not GCed
(transplanted from d9a54fb80b17a0a24c00ca70f253349ac6aea921)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo