Bug 205330 - Files/folders blurred in image file picker
Files/folders blurred in image file picker
Status: RESOLVED INCOMPLETE
Product: platform
Classification: Unclassified
Component: JDK Problems
7.1
PC Linux
: P3 (vote)
: 7.4
Assigned To: Stanislav Aubrecht
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-20 20:04 UTC by monezz
Modified: 2013-07-30 14:39 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Blurred text in image file picker (27.80 KB, image/png)
2011-11-20 20:06 UTC, monezz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description monezz 2011-11-20 20:04:52 UTC
[ BUILD # : 201111171527 ]
[ JDK VERSION : 1.6.27 ]

Content of the image filepicker is blurred when scrollbar is moved.

Steps to reproduce.
http://wiki.netbeans.org/TS_68_FormAndSupportSanity#Test_suite:_Property_editor
Changing component's properties II.

- create a java project
- create a jframe
- put a jbutton on the jframe
- in the property editor of the button choose ... for the icon property
- choose external image and press the ... button
- if not there already navigate to a directory with more then 10 entries
- scroll to the right

Expected result:
- directory content is properly displayed
Actual result:
- directory content is blurred like there is random text printed all over the
place (see screenshot)

When a directory is selected, the column of the selected file/directory is
properly painted.

It is pretty hard to find a picture in a directory containing a lot of pictures
since it is not possible to see where you are with scrolling.
Comment 1 monezz 2011-11-20 20:06:28 UTC
Created attachment 113349 [details]
Blurred text in image file picker
Comment 2 Jan Stola 2011-11-21 15:20:22 UTC
I am sorry, I am not able to reproduce this problem. Could you, please, provide more details? It seems like JDK bug. The corresponding code uses standard JFileChooser and we don't customize its rendering in any way. Are you still able to reproduce this problem? Does it happen also with other file choosers in NetBeans? The attached screenshot seems to be from Nimbus look and feel. Does it happen in this look and feel only or in other look and feels as well?
Comment 3 monezz 2011-11-21 20:55:39 UTC
Reproduced it on java-6-sun-1.6.0.26
With Nimbus and default look and feel

JDK version in the initial report is not right, first encounter was on java-7-openjdk-amd64, just for the record.

I am currently running ubuntu, will test it on ubuntu too, to see if that makes any difference.

The image file picker so far is the only filepicker with a horizontal scrollbar, other filepickers only have a vertical one. The issue appears only with the horizontal scrollbar.
Comment 4 monezz 2011-11-21 21:07:12 UTC
Reproduced on ubuntu aswell, so it does not seem window manager specific.
I also reproduced it in 7.0.1 is it is no 7.1 regression.
Comment 5 Jan Stola 2011-11-22 09:13:25 UTC
> The image file picker so far is the only filepicker with a horizontal
> scrollbar, other filepickers only have a vertical one. The issue appears
> only with the horizontal scrollbar.

What about file-chooser that is opened using File > Open File ... ?

> Reproduced on ubuntu aswell, so it does not seem window manager specific.

I didn't expect it to be window manager specific, but it can be (Java) look and feel specific. Are you able to reproduce it when you start NetBeans IDE in another look and feel, i.e., when you start it with

--laf Metal

or

--laf GTK

command line option? See http://wiki.netbeans.org/NBLookAndFeels for details.
Comment 6 monezz 2011-11-22 12:47:34 UTC
The issue only appears on filechoosers with a horizontal scrollbar.
file->open project -> vertical scrollbar, no issues
file->open file->horizontal scrollbar, blurred content.

I was not able to reproduce this issue on my desktop, but only on my laptop. I will see if I can find some environmental differences, but they seem to be pretty similar. This would point towards some hardware related jvm issue. I searched for JDK bugs but could not find any related issues.

Desktop:

Product Version: NetBeans IDE 7.1 RC1 (Build 201111171527)
System: Linux version 3.0.0-12-generic running on amd64; UTF-8; en_US (nb)
OS: Xubuntu 11.10

Java: 1.7.0_147-icedtea; OpenJDK 64-Bit Server VM 21.0-b17

--laf Nimbus : NOT REPRODUCIBLE
--laf Metal : NOT REPRODUCIBLE
--laf GTK : NOT REPRODUCIBLE

Java: 1.6.0_26; Java HotSpot(TM) 64-Bit Server VM 20.1-b02

--laf Nimbus : NOT REPRODUCIBLE
--laf Metal : NOT REPRODUCIBLE
--laf GTK : NOT REPRODUCIBLE

Laptop:
Product Version: NetBeans IDE 7.1 RC1 (Build 201111171527)
System: Linux version 3.0.0-12-generic running on amd64; UTF-8; en_US (nb)
OS: Xubuntu 11.10

Java: 1.7.0_147-icedtea; OpenJDK 64-Bit Server VM 21.0-b17

--laf Nimbus : REPRODUCIBLE
--laf Metal : REPRODUCIBLE
--laf GTK : REPRODUCIBLE

Java: 1.6.0_26; Java HotSpot(TM) 64-Bit Server VM 20.1-b02

--laf Nimbus : REPRODUCIBLE
--laf Metal : REPRODUCIBLE
--laf GTK : REPRODUCIBLE
Comment 7 Jan Stola 2013-01-08 16:23:58 UTC
> file->open file->horizontal scrollbar, blurred content.

This issue is not specific to GUI builder => I am reassigning the issue to platform though it is probably a JDK issue.
Comment 8 Stanislav Aubrecht 2013-07-30 14:39:47 UTC
Reporter, please check if the problem is reproducible with the latest update of Oracle JDK 1.7 and reopen, thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo